3

Skype keeps starting at startup without my permission. I don't want it to start minimised, there's already a solution for that, I want it not to start. But there isn't a single setting in Skype's options, and Skype is not in my startup applications.

EDIT — as requested, a screenshot of the "session" tab in my Session & Startup settings:

Screenshot

And the weird output of that "grep -lir 'Skype' ~/.cache" command, giving me something about Kingsoft Office:

/home/wolf/.cache/logrotate/status
/home/wolf/.cache/Kingsoft/wps/http/cache_c8034f79bfb82e94e16ff8ebebcfff38262f0359.cache
/home/wolf/.cache/Kingsoft/wps/http/cache_030f47fb47e37a138cb0973e152475a098eeee54.cache
4

I had this same issue (and cross-posted this answer). I was able to prevent it from starting automatically by removing skypeforlinux.desktop from ~/.config/autostart/. I'm using lubuntu; the location of your autostart folder may vary. You can find by using:

$ locate skypeforlinux.desktop

You'll really only want to delete the copy in the directory called autostart, otherwise you won't be able to start the app from the icon.

I'm assuming that the next time you actually, intentionally run Skype (I hope, for the sake of your sanity, that this day is far in the future) that it will try to put that file back. In which case you might have to delete it again or scour Skype for the setting that will prevent that behavior.

  • Or better, change X-GNOME-Autostart-enabled=true to X-GNOME-Autostart-enabled=false in the file ~/.config/autostart/skypeforlinux.desktop EDIT: This applies, if you are using Gnome. It should be similar in other desktop environments. – AdamKalisz Nov 16 '17 at 21:29
0

Three possible solutions, from least to most invasive:

  1. Exit all programs, then open Sessie en opstart and click Sessie opslaan. This ought to overwrite a session file named something like ~/.cache/sessions/xfce4-session-$HOSTNAME:0 which may contain a reference to skype.

  2. Manually edit any files named things like xfce4-session-$HOSTNAME:0 in ~/.cache/sessions/, changing any "skype" to "echo"

  3. sudo mv /usr/bin/skype /usr/bin/spyke – it seems to run fine with a new name, but any calling scripts should fail to find it. You'll have to change/make a new .desktop file if you want clickability.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.