17

I am using Ubuntu 14.04 x64 w/ Unity. I like how the Task Manager shows up in Windows with Shift+Ctrl+Escape. So I tried creating a similar keyboard shortcut in Ubuntu with the command gnome-terminal -e htop.

Nothing happens when invoking that shortcut. However, if I assign a different combination, say Ctrl+Alt+H, it works fine.

What am I doing wrong? Is Shift+Ctrl+Escape reserved or something? It used to work perfectly in 13.10 and before.

6
  • (1) Trying in a terminal, make sure the command works. (2) Why don't you use gnome-system-monitor instead?
    – AliN
    Jun 29, 2014 at 2:08
  • @AliNa: Regarding (1), The command (obviously) works in the terminal, and it works if the shortcut combination is different, as mentioned. As for (2), I like htop.
    – Dune
    Jun 30, 2014 at 6:15
  • 7
    I have opened a bug report: #1350527
    – Cas
    Jul 30, 2014 at 20:17
  • I've just run into precisely the same error. I'll add that you can use dconf-editor to view the actual shortcut configuration live at /org/gnome/settings-daemon/plugins/media-keys/custom-keybindings. Not found a workaround, yet, though. A temporary workaround for me is bind Ctrl-Shift-ScrollLk
    – sehe
    Aug 26, 2014 at 15:07
  • Ah, it works with regular GNOME, just Unity appears to break it.
    – sehe
    Aug 26, 2014 at 16:02

1 Answer 1

1

Use CCSM to assign the command and keybinding and it will work in Unity.

To get Compiz Config Setting Manager do the following:

  • Open the Terminal by pressing Ctrl+Alt+T and type:

    sudo apt-get install compizconfig-settings-manager compiz-plugins-extra -y
    
  • Open CCSM
  • Select the commands option
  • Assign the command on line 0

Select the Keybinding tab and assign the hotkeys you like to trigger the command.

6
  • @snoop: Could you please review my edits and also review the editing help to improve the readability of your questions in the future... ;-) From tomorrow on all your bad edits will be rejected by default. Please do a thorough job or do none at all... Pretty please???
    – Fabby
    Oct 2, 2015 at 21:10
  • @Fabby:your edits are perfect as your are experience person. My some of edits might be not as per expectations but you can reject it and improve it. I am still learning this.
    – snoop
    Oct 3, 2015 at 6:19
  • No worries: You received plenty of examples by now, so I'm convinced the qualities of your edits will skyrocket! ;-)
    – Fabby
    Oct 3, 2015 at 6:25
  • 2
    It does not work.
    – KeyC0de
    Feb 27, 2017 at 10:20
  • 1
    I don't think this answer can work for short cuts with the esc key. See this answer
    – Zanna
    Mar 24, 2018 at 17:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.