I have Natty running fine in my sony vaio vpc-f11 series laptop .

I tried out the instructions in this page.

Now I have my touchpad configured as a generic mouse. So the vertical scrolling works fine. But I would like to have multi-touch features enabled. Questions are as follows :

  • What do I do to get my touchpad recognized as a touchpad rather than the mouse ? or how do I reverse the command I did as per the webpage above ?
  • How do I get multi-touch to work ? None of the pointing devices options seemed to work in the first place... which is why I tried out the instructions in the link posted above.

I am listing my xinput list to clarify my situation :

root@AUM:/sys/devices/platform/sony-laptop# xinput list 
⎡ Virtual core pointer                      id=2    [master pointer  (3)] 
⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)] 
⎜   ↳ HID 1267:c002                         id=10   [slave  pointer  (2)] 
⎜   ↳ ImPS/2 Generic Wheel Mouse            id=12   [slave  pointer  (2)] 
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]    
    ↳ Virtual core XTEST keyboard           id=5    [slave  keyboard (3)]    
    ↳ Sony Vaio Keys                        id=6    [slave  keyboard (3)]    
    ↳ Video Bus                             id=7    [slave  keyboard (3)]    
    ↳ Power Button                          id=8    [slave  keyboard (3)]    
    ↳ UVC Camera (064e:2100)                id=9    [slave  keyboard (3)]    
    ↳ AT Translated Set 2 keyboard          id=11   [slave  keyboard (3)]

Any help would be appreciated ..


wrong answer (: that would work (: (yea, i know it's late, i saw this while writting my question): Vertical Scroll doesn't work on a Sony Vaio VPCEB1S1E

you will find there this link, translate to englist and watch the original at the same time:http://blog.pavelb.ru/2011/10/ubuntu-1110-in-sony-vaio-vpceh-touchpad.html

in short (and english (: ): open nautilus (in terminal-sudo nautlius) go to "etc" >> "X11" >> "xorg.conf".

from like that:

Section "Device" Identifier "Default Device" Option "NoLogo" "True" EndSection

make it look like that:

Section "Device" Identifier "Default Device" Option "NoLogo" "True" Option "RegistryDwords" "EnableBrightnessControl=1" EndSection

Option "RegistryDwords" "EnableBrightnessControl=1"

the answer to your question:

download: http://people.canonical.com/~sforshee/alps-touchpad/psmouse-alps-0.10/psmouse-alps-dkms_0.10_all.deb

and in terminal:

wget http://people.canonical.com/%7Esfors...s_0.10_all.deb

sudo dpkg -i psmouse-alps-dkms_0.10_all.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.