2

I recently upgraded from the smaller AMD barebone brix to the brix pro. The new PC seems to make Ubuntu 14.04 crash on boot, a bug which I can't see anyone with the same PC having (too early?). I've attached the full log but here are the exact variables in play which, in this debugging case, are quite small (thankfully!):

Brand new GB-BXi5-4570R. Corsair 4GB Kit (2x2GB) DDR3L - 1333 SOD/MM Crucial 256GB SSD The rest is not relevant (keyboard, mouse, ethernet)

With a clean hard-drive, I've installed and reinstalled ubuntu 4 times, tried with different HDDs (not the SSD) and even with multiple Ubuntu bootable installs (different USBs and redownloading the ISO). Once the install is done, I reboot and works fine. I run the first update and restart and then I get that log. On one of the reinstallations, it didn't even get to the updating part, crashed on the first reboot. I tried installing as little as possible to see if something in particular is breaking it but all I can tell is that it happens in that update (I can restart multiple times before that with no problem).

The big error comes towards the end of the log and seems to be a kernal panic error, known cause of malfunctioning drivers maybe?

Edit after solution: Turns out it was indeed the -30 kernel that conflicts with the Brix. If you ever get that error, you should simply boot again and go to Advanced Ubuntu Options, select the -24 kernel, and use the solution below (at least until there is a fix to the current kernel).

Full Log

2
  • I'm trying to install ubuntu-gnome from scratch. But I'm also getting kernel panics like that: cdn.mediacru.sh/DGObOxYW-667.jpg But I cannot even get into install - it crashes right during the installation process. – Dannyboy Sep 20 '14 at 3:10
  • Yes, I had that happen as well. What I did to bypass that was kind of hacky but worked: install an earlier version, 13.10, and once it's done, do a live upgrade to 14.04. DON'T RESTART your computer. Before that, use the answer below to switch kernels and then it should work fine. Fyi, 14.04 has a new kernel, -35, which works fine on the brix pro. – ZekeDroid Sep 20 '14 at 18:01
3

I run the first update and restart and then I get that log.

Try this AFTER the update, before the restart.

sudo apt-get install linux-image-3.13.0-24-generic
sudo apt-get purge linux-image-3.13.0-30-generic
sudo update-initramfs -u 
sudo update-grub2

... or if you have the "-24" kernel (or any earlier kernel) under Advanced options ... - try it.

I've had trouble with all kernel updates AFTER -24.

6
  • Ok, trying now. – ZekeDroid Jun 28 '14 at 9:14
  • Oh my god. You are my savior. Seriously. I fought with this for 20 hours straight and going to the previous kernel solved it entirely. I assume this is going to become a big bug which will hopefully get resolved but I don't know of any downsides to having the older kernel. Hopefully it's not a big deal. – ZekeDroid Jun 29 '14 at 7:31
  • =-) -- but seriously, it just proves that you shouldn't take for granted that "all updates will work on your hardware". – Hannu Jun 29 '14 at 9:11
  • An additional comment: kernel.ubuntu.com/~kernel-ppa/mainline/v3.15-utopic works for me (wiki.ubuntu.com/Kernel/… contains info on how to use it). So the bug I filed on launchpad.net is flagged 'kernel-fixed-upstream' – Hannu Jun 29 '14 at 10:14
  • Oh nice, what's the upside of upgrading to this one? Is it worth the trouble? – ZekeDroid Jun 29 '14 at 17:04
0

After upgrading my BIOS on my Brix Pro from F4 to F5, I was able to boot off and install Ubuntu 14.04.01 LTS.

Prior to the BIOS upgrade, I would always get a kernel panic during the bootup of the 14.04.01 ISO image off a USB stick.

Give that a try.

1
  • The new kernel has no problems anyways so problem solved. Thanks though. – ZekeDroid Sep 26 '14 at 4:10
0

In the BIOS under Advanced -> CPU Configuration disable:

  • EIST
  • CFG Lock

Following this you should be able to install with a USB drive. Feel free to enable after installing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.