0

I have a Linode VPS with Ubuntu 12.04.

I had PHP5.3.10 installed and I just upgraded to PHP5.4.30 - by following the instructions given at http://www.dev-metal.com/how-to-install-latest-php-5-4-x-on-ubuntu-12-04-lts-precise-pangolin/

Everything is all good, except, I must have had PHP-SUHOSIN installed (I can't remember, but when I was setting up Linode, it recommended me to do so) and now I'm getting the following message.

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/suhosin.so' - /usr/lib/php5/20100525/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0

I tried

apt-get install php5-suhosin

But I'm getting

The following packages have unmet dependencies: php5-common : Conflicts: php5-suhosin but 0.9.33-1 is to be installed php5-suhosin : Depends: phpapi-20090626 E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

How can I resolve this issue?

1

You can't - php5-suhosin wasn't available for PHP 5.4+ for a long time and thus the package was broken since PHP 5.4. Suhosin upstream author has only recently updated suhosin to support PHP 5.4, but I am not going to prepare php5-suhosin package in my PPA since I don't think it's necessary with recent PHP releases.

And since you clearly don't remember why you had php5-suhosin installed I think you'll be fine without it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.