13

I am running 14.04 with latest update 3.13.0-30-generic. After restarting post update I found that Google Chrome is not launching. I am able to launch Google-Chrome from command line but if I close the terminal window the chrome window closes too! A new icon appeared in launcher so I locked into launcher but after closing the terminal window (the one used to launch Chrome), the icon does not relaunch chrome.

I also found that the incorrect app name appear up in the menu "SecuStore" instead of "Google Chrome"

  • 2
    OK solved:</p> 1) Open you file browser ("Files" in the launcher)</p> 2) Then go up to "edit" in the top of screen menu bar and select preferences.</p> 3) Then tick "Show hidden and backup files"</p> 4) Go back to your file browser and scroll down to ".local" and open the folder.</p> 5) Then open "share" folder.</p> 6) Open "applications" folder.</p> 7) Select every folder with chrome in it's name and trash (empty trash)</p> 8) Open the launcher "Search your computer and online sources" App in the launcher and search for Google Chrome and launch... </p> ...problem solved! – DiGwork Jun 27 '14 at 13:07
  • Please don't add answers as comments. You can post answers to your own questions and delete your own comments, if you feel they're obsolete. – David Foerster Dec 18 '14 at 13:59
  • Ctrl-H is an easier way to make it show hidden files. – SDsolar Jun 29 '17 at 19:39
  • Drat. I found the file but it still gives me the spinner then just quits. – SDsolar Jun 29 '17 at 21:24
16

I was able to fix this by deleting all files in /home/USERNAME/.config/google-chrome/ which forces Google Chrome to regenerate all configuration and profile files. You should be able to do this with a single command:

rm ~/.config/google-chrome/*

Keep in mind that this will delete all of your bookmarks and settings. So (hopefully!) you have them synced with your Google account or backup somehow.

You can change folder's owner.. it worked for me sudo chown username ~/.config/google-chrome/... Good luck.

  • Nope. Same result. Spinner but no start. – SDsolar Jun 29 '17 at 21:25
  • @SDsolar use sudo rm -rf ~/.config/google-chrome/* It will delete all files and folders under google-chrome folder – Sisir Oct 5 '18 at 17:41
14

I had the same issue when I run google-chrome from terminal,

I found that it needed a new version of NSS: Chrome 62 need NSS>=3.26. So I installed libnss3.

$google-chrome

[6999:7036:1113/200616.549496:FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Aborted (core dumped)

sudo apt-get install --reinstall libnss3

and it started working.

  • 1
    cool... this doesn't deletes my bookmark.. this should be the correct answer, since bookmarks are crucial (which I have tons)... – x-code Dec 15 '17 at 4:59
  • Awesome. This work for me. I had issue with chrome 63 and latest chromium browser with Ubuntu 14. It resolved for both the browsers. – Tabish Jan 21 '18 at 18:30
  • Admire your effort! – Onik Mar 1 '18 at 20:01
  • Had the same issue, when I click Google Chrome it will appear and disappear quickly. Reinstalling libnss3 solved the problem for me. Thank you very much. – JRulz Jul 23 '18 at 13:53
3

I could not get Chrome to start if I downloaded the installer from Google's website. But, I found that if I used the terminal command sudo apt-get install google-chrome-stable it installed and worked.

  • Here it is 2017 and that is not found, nor any other variation I tried. – SDsolar Jun 29 '17 at 21:27
  • sudo apt-get install google-chrome-stable is worked for me in 2017 .thanks – Kshitij Soni Jul 13 '17 at 5:20
0

You also may have to show hidden files and go to .config. For me, the rights to the google-chrome directory in there got set to root so I had no rights for google-chrome to create directories as needed. Change the owner to your login, folder access to Create and Delete files, group to your login, and access files as folder access for group and Other.

I used nemo (in LinuxMint) with elevated privileges to do this. It can be done with the command prompt commands but I'm not to familiar with them yet.

After this change google-chrome now runs.

Hope this helps.

0

Here we are in 2017. Things have changed some.

I just had this happen and fixed it today. And yes, it says Chromium.

After trying the usual remedies I found all over the web such as navigating into various local directories and clearing out files, etc., it still wouldn't work.

I couldn't even uninstall it and try a reinstall because I didn't know the package name.

So here is what worked:

Go into the Ubuntu Software Center (Press the Windows key and type "soft" and it will find it)

Search for Chromium - It found it when I typed just "chro"

I told it to uninstall it. Took just a minute or two.

Once uninstalled, I rebooted.

Then I went back into the Ubuntu Software Center, searched for it again then told it to install it.

It did so.

And it worked.

Then when I logged it back into Google (from the Settings menu) it restored my extensions and bookmarks and everything. (The former Chromium wouldn't connect to Chrome settings but they have updated it so it works fine now)

Now it is acting normal.

protected by A.B. Jul 11 '15 at 16:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.