After my laptop lost power last night, I logged on today to find my encrypted home directory not mounted. Since I have recently changed my login password, I used ecryptfs-rewrap-passphrase /home/.ecryptfs/$USER/.ecryptfs/wrapped-passphrase to rewrap my passphrase, using my old login/ecrypt passphrase, and entering my new login/ecrypt passphrase. This had worked in the past. I logged out, and logged back in, and, no good home directory. I had forgotten about ecryptfs-mount-private, so I tried it again, but this time the screen went black and it just sat there for a while. I stupidly then just turned the laptop off. Then restarted, logged in, and this time tried ecryptfs-mount-private. I get: Enter your login passphrase: Error: Unwrapping passphrase and inserting into the user session keyring failed [-5] Info: Check the system log for more information from libecryptfs ERROR: Your passphrase is incorrect ...though I know I'm entering the correct passphrase.

When I did sudo ecryptfs-recover-private It did indeed find it: Inserted auth tok with sig [xxxxxx] into the user session keyring INFO: Success! Private data mounted read-only at [/tmp/ecryptfs.vZCfaWzw].

Ok, so what do I do next? Should I go into full recovery mode and copy the found directory to another disk, and start from scratch? Or should I try: ecryptfs-wrap-passphrase /home/.ecryptfs/$USER/.ecryptfs/wrapped-passphrase ...hoping that I can give it the original mount password, and then my login password again. Or???

I'm a in a bit of a panic, and am worried I'm going to screw things up more. Any help would be most appreciated! The man pages are very terse and unclear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.