4

I noticed when I try some packages, I get sometimes this error:

<pkg_name> Depends: <an_other_pkg> (>= version X.X.X) but it is not installable.

What does is mean ' but it is not installable.' ?

3
<pkg> Depends: <an_other_pkg> (>= version X.X.X) but it is not installable

This package depends on other package version X.X.X which isn't installable because the needed package is no longer available in the repositories. So it is not installable.

  • Does that mean all what I have to do is to edit /etc/apt/sources.list with the appropriate repository ? – user284234 Jun 26 '14 at 12:08
  • yep. But older version of packages are not maintained. You have to add the repository or PPA which contains that needed specific version. – Avinash Raj Jun 26 '14 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy