4

Till now I'm working with ubuntu 12.04 on a standalone pc (no display,mouse,keyboard).

I installed xrdp and i'm using windows remote desktop connection.

It's working fine with juste one adjustment : put that in the .xsession

gnome-session --session=ubuntu-2d

This morning I tried installing ubuntu 14.04, xrdp, .xsession adjustment and ... no working anymore. Only a grey screen with a X mouse cursor.

After lot of search and reading on internet it seems it's not more possible to use ubuntu-2d with 14.04. Only xfce is working. But I don't want to use xfce !

So what's the solution ?

  • xrdp with windows remote connection : works only with xfce
  • teamviewer : it's working but everything I do is visible on the server (if a screen is connected) and the session remains open if I do not logout before I quit teamviewer client (so someone can connect a keyboard to the server and use it)
  • x2go : seems not working fine with 14.04
  • desktop sharing : not working. I'm using ultravnc and I got No security type suitable for RFB 3.3 supported
  • ... ?

It's so easy with windows ... The only thing I want is to connect to my server, open a remote session and work. Is it impossible mission ?

0

I use remmina without problems, have you tried that?

I like it as it stores all my servers settings so I can simply switch from one to another.

  • No, didn't know remmina. Just have a look on internet. But I don't understand. It's only a client ? If so what server do you use ? And I think it's not possible for my 'main' pc running under windows. – tweetysat Jun 26 '14 at 12:41
  • @tweetysat AFAIK, the default Ubuntu desktop comes with Vino (or at least enabling desktop sharing in the Sharing settings enables it). Vino is good enough VNC server. – muru Jun 26 '14 at 18:29
0

can i recommend lubuntu(14.04.5); tested working vith virtualbox

apt-get install xrdp
nano /etc/xrdp/startwm.sh > last line . /etc/X11/Xsession
home folder > show hidden > .xsession > add any of the 3 following lines
    lxsession -e LXDE -s Lubuntu
    lxsession -e LXDM -s Lubuntu
    lxsession -s Lubuntu
service xrdp restart(..not required)

you can change various xrdp settings

nano /etc/xrdp/xrdp.ini 
service xrdp restart

How to Remote Desktop from Windows to Lubuntu

seems ubuntu(14-16) is bugged regarding any rdp as it requires hardware acceleration

[bugs] gnome-session is broken without 3d acceleration

[bugs] gnome-session-flashback/Unity fails to start without hardware acceleration

-1

from ubuntu 12.10 ~

gnome-session --session=ubuntu-2d
gnome-session --session=gnome-fallback

use hardware accelerator... Does not support

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.