0

I'm using Windows 8.1 with Ubuntu 14.04 with uefi dual boot. I had to force shut down Ubuntu after it hanged. Since then internet is not working in ubuntu while everything is fine in windows. Attaching the photos of outputs of some commands I ran to check things.

Looks like my router is connected to the laptop just fine. I can't understand where the problem lies since Windows isn't having any.

Thanks in advance for your help. ifconfig and route -n ping outputs and grep proxy /etc/environment nm-tool output part 1 nm-tool output part 2

Edit: some more outputs enter image description here

  • Do you use DNS cache (nscd)? – OdinRW Jun 26 '14 at 7:51
  • Please remove all those screenshots and rather add the code as text to your question and format it as code block! – derHugo Nov 5 '17 at 14:32
  • @derHugo I would have done that. However, since the internet was not working, I had to type on my phone. Don't have access to these outputs any more. Sorry for the inconvenience. – stranger_anon Nov 7 '17 at 6:07
2

There are many reasons why you might get such problems. You are connected to router but not the internet. I will suggest two solutions.

If you have nscd installed then try this

sudo /etc/init.d/nscd restart

If not then try to release and renew the IP

sudo dhclient -r eth0
sudo dhclient eth0
  • But he IS connected to the internet – meccooll Jun 26 '14 at 7:59
  • And he's connected through eth0 NOT wireless – meccooll Jun 26 '14 at 8:01
  • He is connected to the internet true. but if there is IP conflict in the internal network (which we have no information about it) then it might cause problem. He can also use arp-scan to give more info but atm let's try to narrow it – OdinRW Jun 26 '14 at 8:01
  • True story :p I have wireless so was trying the command here before posting it :) – OdinRW Jun 26 '14 at 8:02
  • Yeah possible but doesn't feel like ip conflict, he'd have dropped pings and other issues this is consistent DNS problems – meccooll Jun 26 '14 at 8:12
1

Your internet is working as show by successful pings to 4.2.2.2.

Whats not working is you DNS translations from google.com to its IP.

You're setting your DNS servers to 64.59.144.93 and 64.59.150.139 are you sure that's correct?

Try

nslookup google.com 64.59.144.93

and

nslookup google.com 64.59.150.139

if they don't respond try using public dns servers like

nslookup google.com 8.8.8.8

or 8.8.4.4 or 4.2.2.2.

  • You are definitely on to something! But the DNS seem fine. Nslookup returns a different list of IP addresses for both dns. Ping gives 0 packet loss for every IP on that list. Even entering them directly to the browser address bar starts Google. However pinging Google still doesn't work. – stranger_anon Jun 26 '14 at 6:56
  • Show your nslookup ubuntu.com, cat /etc/resolv.conf, and cat /etc/network/interfaces – meccooll Jun 26 '14 at 7:10
  • Added an edit!! – stranger_anon Jun 26 '14 at 7:37
  • Do dig ubuntu.com So it'd use whatever DNS it thinks it's suppose to. i'm speculating that it'd try 127.0.0.1 instead of 64.59.144.93 – meccooll Jun 26 '14 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.