I know this question has been asked a lot. I've tried all the solutions, such as formatting, reboot, remount, etc. But my microSD still read-only.

I have partitioned my Micro SD into 2 partitions and 1 of partition I mount it as /data in my android and the last one as SD card.

/data is one of the storage space in android (ex : /system, /data, /cache, /etc)

OS : Ubuntu 14.04

  • Is your SD card RW enabled when plugged in to PC? – Ruslan Gerasimov Jun 26 '14 at 2:54

Did you try gparted sudo apt-get install gparted? I had the same problem with my new microsd card. Download gparted and format the microsd card to FAT 32 and then unmount/remount. Ubuntu will recognize the card. WARNING this will erase all contents on the card, however the formatting will solve the unreadable properties.

| improve this answer | |
  • I have tried with gparted and with dd, in both cases the drive stays write protected. I even did a full scan and didn't found any issues – Pini Cheyni Jul 13 '17 at 11:10

Have you tried a different card reader? I've noticed that, for whatever reason, some of my MicroSD cards insist on going read-only with some USB-SD adapters and not others and which adapter to use depends on which card I'm using.

| improve this answer | |

A temporary quick solution:

First check the device name

sudo fdisk -l

And the unmount and remount it (assuming your device is /dev/sdc1)

sudo mount -o remount,rw /dev/sdc1
| improve this answer | |

Are you using a Micro SD card to full-size SD card adapter? Some of those adapters have a lock switch on the left side. I re-inserted a card about 10 times wondering why it was suddenly only mounting read-only before I noticed that switch had slipped slightly out of the unlocked position.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.