Every day, at a random time, my ancient laptop becomes unusable. Something decides to consume the entire 1GiB of RAM plus several hundred MiBs of swap, and thrash my hard drive. It brings the computer to its knees for 15-30 minutes.

I have set update-manager to never check for updates, I have set update-notifier to not run on startup.

This just happened yet again, and I found update-apt-xapi running, consuming 100% cpu. When it went away, my computer became usable again. Other than that, there's no obvious culprit for this large memory consumption and crippling of my machine.

How can I stop my computer from locking up every day?

This is an ancient laptop with 1GiB RAM, running Xubuntu 14.04

3 Answers 3


One forum thread says Synaptic's search function is affected if you remove apt-xapian-index.

You can disable the periodic updates by adding this line:

APT::Periodic::Enable "0";

to a file called /etc/apt/apt.conf.d/99periodic-disable (I picked that name. You can change it, as long as you keep the 99 in front, if you don't like it).

I have no idea if the Synaptic search is still usable after you do this, but I prefer this solution to others, as it doesn't affect config files (that won't be updated on next package upgrade because of local changes), doesn't change permissions (that will be restored on next package upgrade) and Synaptic (if you use it) might still be a happy bunny.


Try removing package apt-xapian-index. You will lose command axi-cache and some bash tab completition for apt-get but you will get your computer back.


In my case @today

$ chmod a-x /etc/cron.weekly/apt-xapian-index
$ echo 'APT::Periodic::Enable "0";' >> /etc/apt/apt.conf.d/10periodic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.