I'm new to Ubuntu. In my system WIFI is working fine but Ethernet is not working fine.

ifconfig -a

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:13703 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13703 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1263769 (1.2 MB)  TX bytes:1263769 (1.2 MB)

wlan0     Link encap:Ethernet  HWaddr 0c:60:76:65:d7:c2  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::e60:76ff:fe65:d7c2/64 Scope:Link
          RX packets:418816 errors:0 dropped:0 overruns:0 frame:464023
          TX packets:367793 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:544360588 (544.3 MB)  TX bytes:32354669 (32.3 MB)
          Interrupt:17 Base address:0xc000 

when I'm trying to get eth0 i am getting an message like

ifconfig etho

etho: error fetching interface information: Device not found" 

and I have done lspci | grep -i eth it returns nothing.

could you provide solutions for this?

  • Typo caused the error in the title, but there's no clue here as to the real issue – Zanna Sep 12 '19 at 3:17

The fact that ifconfig -a does not list eth0 means that your wired adapter hasn't been found. Things to check:

  • lspci - is you network adapter listed?
  • Reboot and enter bios setup. Check if the built in network adapter is enabled.
  • Thank you for your valuable solutions. It's working Now :) – Rajiv Reddy Jun 26 '14 at 1:37

In my case I solved a problem where I had no wired ethernet (but wireless worked). I tried sudo dhclient and that did not fix the issue, at least right away. Next, I rebooted and toggled the 'Enable Onboard LAN' setting from the BIOS. Then wired ethernet worked again for me.

Note that to get into the BIOS, you'll need to press F2 or F10 or your system's specified key, and then in once in the BIOS you'll need to find the 'Onboard LAN' setting.

  • +1 for recommending dhclient. Thanks that solved my problem. New install opted to manually configure so dhclient wasn't running. – barrypicker Sep 12 '16 at 1:28

Also adding few points that has helped me solve similar problems alongside what @sMurf has replied to;

You can verify if the MAC address found on the device is same as that present in the /etc/udev/rules.d/*-persistent-net.rules

This is more relevant if you are making use of a VDI image in Virtual Box or the equivalent environment. If in Virtual Box environment, goto "Machine -> Settings -> Network" and verify that the MAC address' match. If they don't, then you can edit with the correct fields in the above mentioned file and restart the VM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.