i installed dhcp3-server , now i want to start its service and it said : [FAIL] Starting ISC DHCP server: dhcpd[....] check syslog for diagnostics. ... failed! failed! i check ps aux | grep dhcp shows :

root 6178 0.0 0.0 9956 3708 ? S 23:06 0:00 /sbin/dhclient -d -4 -sf /usr/lib/NetworkManager/nm-dhcp-client.action -pf /var/run/dhclient-wlan0.pid -lf /var/lib/dhcp/dhclient-eee3fc61-32c1-4aa7-b189-94556369eac2-wlan0.lease -cf /var/run/nm-dhclient-wlan0.conf wlan0 root 6418 0.0 0.0 7764 860 pts/0 R+ 23:13 0:00 grep dhcp

dhcpd.conft is like default , before that i tried to implement a dhcp server on my at0 but i couldn't . if need a details just said . `i tried to remove it but :

[FAIL] Stopping ISC DHCP server: dhcpd failed!

i don know what can i do now ?! how can i fix it ? or delete it ?

up vote 0 down vote accepted

What does the file /var/log/syslog show? That's where the diagnostic information will be.

If I had to guess, I'd say you don't have a static IP address configured for your interface that you have dhcpd set to run on. You need to add one in /etc/network/interfaces

  • i config static ip to my at0 ; and this is the last ten line of syslog : ` No subnet declaration for wlan0 (192.168.1.3). Jun 25 23:21:20 bahram dhcpd: ** Ignoring requests on wlan0. If this is not what Jun 25 23:21:20 bahram dhcpd: you want, please write a subnet declaration Jun 25 23:21:20 bahram dhcpd: in your dhcpd.conf file for the network segment Jun 25 23:21:20 bahram dhcpd: to which interface wlan0 is attached. ** ` i think you right ; i clean my dhcp and my at0 and tried to start service dhcpd maybe you right, tnq – Bahram Jun 25 '14 at 19:05
  • You need to configure a static IP for the wlan0 in /etc/network/interfaces – Bert Jun 25 '14 at 19:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.