I just installed Linux and Ubuntu 14.04 alongside my Windows 8 on my HP Pavilion. First, I had problems with the graphics card and it said it could only operate in low graphics mode.But it just stall when I tried this.

I have Googled some potential fixes for this, but they all require an Internet connection which I am unable to obtain. I can boot in recovery mode, but I can't connect to either a wired or wireless connection. It can see both but can't connect, just keeps trying to connect.

Any help on either issue would be greatly appreciated.

$ sudo lshw -c network 
  *-network               
       -description: Wireless interface
       -product: RT3290 Wireless 802.11n 1T/1R PCIe
       -vendor: Ralink corp.
       -physical id: 0
       -bus info: pci@0000:08:00.0
       -logical name: wlan0
       -version: 00
       -serial: 54:35:30:80:eb:01
       -width: 32 bits
       -clock: 33MHz
       -capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       -configuration: broadcast=yes driver=rt2800pci driverversion=3.13.0-29-generic firmware=0.37 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:18 memory:c2610000-c261ffff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 08
       serial: a0:1d:48:e4:ff:c4
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8106e-2_0.0.1 04/23/13 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:59 ioport:4000(size=256) memory:c2504000-c2504fff memory:c2500000-c2503fff

$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr a0:1d:48:e4:ff:c4  
          inet6 addr: fe80::a21d:48ff:fee4:ffc4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:36631 errors:0 dropped:0 overruns:0 frame:0
          TX packets:189 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2200377 (2.2 MB)  TX bytes:38826 (38.8 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:191 errors:0 dropped:0 overruns:0 frame:0
          TX packets:191 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:13717 (13.7 KB)  TX bytes:13717 (13.7 KB)

wlan0     Link encap:Ethernet  HWaddr 54:35:30:80:eb:01  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

I figured it out. Thanks everyone for your help.

It was a combination of two problems:

https://superuser.com/questions/756145/ubuntu-14-04-wired-connection-detected-but-no-internet-access

That worked after I did some other stuff to allow the changes to be saved, and then I went to the settings and used the proprietary drivers as suggested below, although it didn't work the first time. I had to reinstall in order to achieve success.

  • 1
    post sudo lshw -c network and ifconfig -a – meccooll Jun 25 '14 at 18:27
  • Hi thanks for the response. I've added those commands to my post. My appologies for the poor formatting. Is there a better way? I was unmable to add to your comment. – Langleson Jun 26 '14 at 14:53
  • Can you please post your solution? I have the same issue. Thanks – Waiyl Karim Mar 2 '15 at 18:44
  • Hi, sorry for the delay. I honestly can't remember exactly what I did; however, I think it was part of a bigger problem. I was using an old router that did not have WPA2 capability, so I was using WEP. I have since got a new router and the problem does not exist anymore. – Langleson Apr 2 '15 at 22:29
  • also post rfkill list – user3113723 May 7 '15 at 3:00

Going on assumption that you're plugged into a router that gives out IPs automatically (DHCP), try sudo dhclient -r then sudo dhclient eth0 if successful try ping 8.8.8.8 post results if it didn't work

  • My appologies for the inexperience. My router is a D-Link 802.11g/2.4GHz Wireless router. The modem is a Motorola SB5102. I beleive your assumption is correct. With windows it seems to connect automatically. When I try the commands above, I log into ubuntu in recovery mode and open a terminal. When I enter 'sudo dhcclient -r', there is no output. When I enter 'sudo dhclient eth0, it seems to do somthing, as the command line does now return. At this point I enter the ping command and press enter, but nothing happens. The command line doesn't return unles I press ctrl+z. – Langleson Jun 27 '14 at 19:48
  • I figured it out, thanks for your help – Langleson Jun 28 '14 at 0:32
  • 1
    Share your solution to the problem so others can benefit – meccooll Jun 28 '14 at 0:33
  • yes, works on 15.10 – truongnm Apr 19 '16 at 3:02
  • 2
    This made it temporary work for me, but not after restart again. Why? – embe May 20 '16 at 19:32

I had a similar problem with my HP Pavilion, but only with the wireless.

Here's how I fixed it:

After booting up run sudo service network-manager restart.

Then my wireless started working.

Go to System Settings->Software&Updates-> Additional Drivers

If there is a proprietary networking driver available, enable it.

Restart the computer, and it should connect.

  • Thanks for the input, but it didn't work. It keeps trying to connect and then asking me for the log in credentials. – Langleson Jun 26 '14 at 17:03

Here is how I solved it. I edited /etc/resolv.conf with administer rights. There was one line

# Generated by NetworkManager

I added the line

nameserver 192.168.1.1

which is most router ip addresses. If you have a different router ip address use that.

Extra information. Before I did this I was able to access the router by typing in the ip address. I was able to ping ip addresses but not urls. That's when I realised I had a DNS problem. I tried editing the DNS ip address using network manager but it didn't work. Actually my name server has a different ip address but the one I provided wi

  • thanks, this worked for me -- after upgrading to ubuntu 18.04 bionic – woohoo May 24 at 1:09

I had the same issue. For me editing the /etc/network/interfaces file resolved the issue.

What I did was edited the line:

iface lo inet telnet

to:

iface lo inet dhcp

Hope this helps.

I can simply solve the problem by doing the following:

gksu gedit /etc/NetworkManager/NetworkManager.conf

Then I just change "false" in the file to "true" and then save and restart (only network manager restart can also work)

  • 2
    can you explain what which value to edit? what's the default text. some people might not understand the answer – Sumeet Deshmukh May 7 '17 at 16:09

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.