I have installed Ubuntu 14.04 LTS Server, and then added a minimal desktop like so:

sudo apt-get install ubuntu-desktop --no-install-recommends

Then I complemented the install with the following packages so I could get a usable UI:

sudo apt-get install gnome-disk-utility gnome-terminal libpam-gnome-keyring 
libproxy1-plugin-gsettings libproxy1-plugin-networkmanager network-manager-gnome 
network-manager-pptp network-manager-pptp-gnome ttf-ubuntu-font-family xdg-utils 

sudo apt-get install unity-control-center unity-lens-applications unity-lens-files 
indicator-session indicator-power indicator-keyboard indicator-datetime 
indicator-sound indicator-application indicator-appmenu hud

It almost works perfectly. except for the network.

I configured a wired connection using fixed IP address GUI as follows:

enter image description here

But regardless, my IP is always chosen at random and the connection keeps showing as never used in the UI despite multiple reboots.

If I click on the networking icon and the in "Connection Information" I get the following:

enter image description here

ipconfig -a gives me this:

administrator@ci-server:~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:0c:29:f2:c6:26  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::20c:29ff:fef2:c626/64 Scope:Link
          RX packets:4991 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3162 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2295739 (2.2 MB)  TX bytes:479519 (479.5 KB)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:35233 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35233 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5458696 (5.4 MB)  TX bytes:5458696 (5.4 MB)

What am I missing? Did I forget any packages to make this UI work?

**UPDATE: ** This is my /etc/network/interfaces file:

administrator@ci-server:~$ cat /etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

Thank you!

  • Post your /etc/network/interfaces if that's configured it should overwrite network manager – meccooll Jun 25 '14 at 17:24
  • It seems you got it! It is configured for dhcp... should I delete this file? Or just remove the configs for eth0? – Edy Bourne Jun 25 '14 at 17:29
  • Is the connection marked as "system connection" in Network Manager (I think it is under "general")? And --- there is a very old bug (can't find the reference now) that require you to change the name of the connection and save it to have it really saved... – Rmano Jun 25 '14 at 17:39

I prefer to manage my interface through /etc/network/interfaces for static IP on eth0 you can set yours to

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

if you prefer to use the network manager GUI comment it our per @chili555 answer

  • Thanks again! Marking yours as the answer since I fixed it due to your comment. – Edy Bourne Jun 25 '14 at 19:39

I suggest you comment out your eth0 setting in /etc/network/interfaces thus:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
#auto eth0
#iface eth0 inet dhcp

Restart the computer and you should be all set.


Follow some Step to solved your problem.


  1. Check your LAN cable it should be work with proper connection otherwise check your Network Cable with LAN Tester device. and plug your Network cable to your computer.
  2. Open terminal run the command
    sudo mii-tool
    eth0: link up, 100Mbps, full-duplex
  3. change your Lan Card duplex mode to run the following command in your terminal
     sudo mii-tool -F 10baseT-HD
    eth0: 10 Mbit, half duplex, link ok

Try it.........

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.