I have an Ubuntu machine named ci-server, with wired connection and fixed IP address of

When I ping by IP I get the following output:

administrator@ci-server:~$ ping
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable

Note that it started resolving to the correct IP, but then subsequent message had a different IP.

If I do by name it resolves to localhost correctly:

administrator@ci-server:~$ ping ci-server
PING ci-server ( 56(84) bytes of data.
64 bytes from ci-server ( icmp_seq=1 ttl=64 time=0.019 ms
64 bytes from ci-server ( icmp_seq=2 ttl=64 time=0.038 ms

The route command gives me this:

administrator@ci-server:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    0      0        0 eth0     *        U     0      0        0 eth0

and is the correct gateway.

I'm not sure about that second entry over there.. should that be removed?

The traceroute doesn't seem useful:

administrator@ci-server:~$ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1 (  2998.079 ms !H  2997.933 ms !H  2997.921 ms !H

This is a VM running on VMware Workstation using bridged network. I cannot ping it from the host, and other VMs cannot ping each other. They were cloned from a template machine so they all have the same issue.

I don't know how to proceed with this. When a process (Tomcat Ant tasks) tries to reach another machine in my network by name, it fails with "java.net.NoRouteToHostException: No route to host".

Any help with this is greatly appreciated!

up vote 3 down vote accepted

What makes you think that your IP is From the looks of it it's ci-server just resolves to you should always be able to ping it. Post ifconfig -a to be sure of IP

  • Damn you're right, ipconfig shows! I have configured the network using the GUI, and it seems correct there but for some reason those settings are not being used.. I'll update the question. Thanks! – Edy Bourne Jun 25 '14 at 17:09
  • On a second though, you found the issue here, so I'll mark it as Accepted and open a new question for why my settings are ignored. Thanks! – Edy Bourne Jun 25 '14 at 17:11

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.