I have a node that has successfully been commissioned into a MAAS pool, i.e., got Declared->Commissioned->Ready. After it got to Ready state, I issued juju add-machine to put it in Allocated state; however, upon boot up, I get the following messages:

cloud-init-nonet [18.88] waiting 10 seconds network device  
cloud-init-nonet [20.93] waiting 120 seconds network device
cloud-init-nonet [148.93] gave up waiting for network device

This node is a Y500 Lenovo laptop, and I had to make the following modifications:

  1. Its BIOS is set to Legacy with boot priority set to UEFI 1st
  2. On the boot up grub menu, I added nomodeset, to the end of linux argument line. It should be noted that the 2nd step was initiated, after node was set into Allocated mode, to avoid hang up on nouveau driver, during boot up. I also tried adding ether=0,0,eth0 to the linux argument line to no avail.

My initial inclination to blame UEFI as the root cause of the problem, has proven to be unfounded. Here is what I see now:

  1. Intermittently, allocated nodes may get stuck waiting for network device, e.g., after 4-5 reboots my Y500 node finally got through, and I was able to deploy it as a nova-compute. I have also noted that rebooting an existing node, say cinder or another nova-compute, results in the same behaviour, which is rather odd, as 2 weeks ago I deployed them with no such problem.
  2. The work around, for deployed nodes, is to login in single mode, add a password for ubuntu user, reboot, login with new credentials, and issue dhclient br0. I've also have noted that prior to issuing dhclient, br0 is not listed in ifconfig.
  3. The problem that I was observing with regard to MAAS server also wanting to obtain a dhcp IP address, seems to have been due to mismatch between /etc/network/interface and Network Manager. Setting the relevant fields identically in both, gets rid of the annoying dhclient process.

I haven't been able to ascertain any new information by going through cloud-inits log files. If there are suggestion, kindly, let me know.

(Not sure if this is relevant, but I started seeing this problem as I tried to add 2 more nodes, to existing 10 node setup.)

  • That error usually happens if your DHCP server is not running, or is not responding to DHCP requests on the interface cloudinit is expecting to find an address. On your MaaS server, can you tail -f /var/log/syslog and see if DHCP requests come in? Also, which version of Ubuntu are you installing on the system? I suggest you enter in single user mode, set a password for root and try to debug. do a simple dhclient on eth0, see if you get an IP. – Gabriel Samfira Jun 25 '14 at 19:32
  • DHCP server is behaving strangely, which is odd as MAAS dhcp server worked fine during commissioning state. Prior to boot from disk phase, dhcp log shows proper transaction, e.g.,pastebin.ubuntu.com/7702909, where is the assigned IP to the new node, with MAC 28:d2:44:03:d3:ed. However, just prior to getting the nonet message, this happens pastebin.ubuntu.com/7702917, which is very odd as MAC fc:4d:d4:3d:20:eb refers to MAAS server, with fixed IP! Will follow up with single user mode logs. – Nastooh Jun 25 '14 at 22:18
  • When you follow up please edit your question with the right information, we need the proper information in the question, not buried in the comments, thanks! – Jorge Castro Jun 26 '14 at 19:45

Dumb question on my part, but could you paste a copy of your /etc/network/interfaces ? I've found out that the way in which devices are brought up in there is somewhat order dependent and has iffy behavior if say the bridge starts first and the card starts after.


Hi this happens to everyone when you have more than one card and maybe a bridge


There also a bug open:


Hope someone will solve this

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.