5

I cannot find it from:

enter image description here

I cannot even turn bluetooth on from:

enter image description here

I can connect to this speaker from my Android phone, so I guess the problem is in Ubuntu 14.04.

I tried:

$ sudo hciconfig hci0 reset 
Can't init device hci0: Operation not possible due to RF-kill (132)
$ sudo rfkill list
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: asus-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
7: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

$ sudo rfkill unblock 2
$ sudo rfkill unblock 7

Now I can turn it on, but adding device button is disabled.

enter image description here

2
  • This sound like your bluetooth is blocked. Please try the answers from askubuntu.com/q/153384/40581
    – LiveWireBT
    Jun 27, 2014 at 12:53
  • 1
    Try booting into your bios - look for a BIOS setting labelled "XHCI PRE-BOOT MODE" - is it enabled? Try disabling it - if you have USB3 ports this may reduce these to USB2 speeds.
    – fossfreedom
    Jun 27, 2014 at 15:09

4 Answers 4

3
+50

potential reason why...

converting my comment to an answer

Issues such as this are mostly due to kernel issues. The kernel is the key underlying component that interfaces between the physical hardware and presents this in a controlled way that desktop software can usefully use and allow the user to control.

Bluetooth dongles are mostly USB based. Most hardware today are USB2 based or USB3 based. The kernel uses different modules to interrogate these two versions.

Assuming you are using USB3 to connect, there may be an underlying issue with the USB3 kernel module called XHCI.

so what can I do...

You should really test the latest kernels (at the time of writing 3.16 series) - but if you want continued support you need to work with the Canonical kernel developers to identify a solution. Raise a bug-report - include details of the bug report that you've installed the latest kernels and they did/didnt work etc.

As a workaround, many BIOS's have the ability to downgrade USB3 ports - downgrade them to USB2 speeds. This is called "XHCI PRE-BOOT MODE"

If you disable this mode, this should force the kernel to see your bluetooth device as a USB2 based device.

1

Install driver packages and all the necessary packages for bluetooth devices to work:

sudo apt-get install bluez bluez-alsa bluez-audio bluez-btsco bluez-compat bluez-cups bluez-dbg bluez-gstreamer bluez-hcidump bluez-pcmcia-support bluez-tools bluez-utils python-bluez bluewho indicator-bluetooth libbluetooth-dev libgnome-bluetooth11 libbluetooth3 python-gobject python-dbus
2
  • 1
    I installed all of this, but no change. My device is detected, but as unknown, and I can't connect it
    – Kostanos
    Nov 16, 2015 at 14:51
  • devices are shown in the search result but pairing fails Jan 9, 2016 at 4:21
0

I had the same problem, it was solved when selected mode (in sound setting) to High Fidelity Playback(A2DPslink)

-1

For Ubuntu 14.04 LTS:

1) Go to the bluetooth icon, typically top right of your screen

2) Set Up New Device...

3) Device type: Headphones... other audio devices.

That should make the speakers visible. Select, continue & enjoy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.