I would like to view screen shares and share my screen via WebEx. I have Firefox installed on Ubuntu 14.04 (64-bit). I can join a meeting, but when I try to share my screen or see others' screens, nothing happens. What do I need to do?


2 Answers 2


If you can join the meeting, Java (OpenJDK 7) is working correctly. You just need to install the following 32-bit packages:

sudo apt install libpangoxft-1.0-0:i386 libxv1:i386 libpangox-1.0-0:i386

Source: http://ubuntuforums.org/showthread.php?t=2220667&page=2&p=13053998#post13053998

(See that thread for details on identifying required packages. You may need to do this again once 14.10 and future versions come out. The relevant links are http://linuxsagas.digitaleagle.net/2014/02/07/webex-on-64-bit-ubuntu-13-10/ and How to I make Cisco WebEx work with 13.10 64bit? )

  • are you using amd64 openjdk version? Oct 11, 2015 at 17:58
  • doesn't work for me. Audio devices are not accessible Apr 21, 2016 at 9:46

https://gist.github.com/mshkrebtan/407786e334847544b40e7d6a8a53d247 explains how to run WebEx w/ audio and screen sharing under 32-bit Firefox on a 64-bit Ubuntu OS. Many thanks to Paul Rougieux who found it!

Enable support for 32-bit executables

Add i386 architecture to dpkg architectures but running sudo dpkg --add-architecture i386

Install the libraries required to execute ELF-32 executables by running sudo apt-get update && sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

Download the 32-bit Linux download of Firefox ESR 68 (Note: The original instructions called for ESR 54, and if you have that installed, go with it instead). If installing Firefox ESR 68, install it (here using /opt/webex) by running sudo mkdir -p /opt/webex/ && sudo tar -xjvf firefox*esr*.tar.bz2 -C /opt/webex/

Install the libraries required for Firefox (i386) to run smoothly:

sudo apt-get install \
    libgtk-3-0:i386 \
    libasound2:i386 \
    libdbus-glib-1-2:i386 \
    libxt6:i386 \
    libxtst6:i386 \
    libcanberra-gtk-module:i386 \
    libcanberra-gtk-3-module:i386 \

Install 32-bit JRE

Download Oracle JRE for Linux (a tar.gz archive for x86 architecture) from Oracle and unpack it to /opt/webex/ with sudo tar -xzvf jre*linux-i586.tar.gz -C /opt/webex/ && sudo mv /opt/webex/jre* /opt/webex/jre

Enable Java support in Firefox

Create symbolic links for the Java browser plugin libraries:

sudo mkdir /opt/webex/firefox/plugins/
ln -s \
    /opt/webex/jre/lib/i386/libawt.so \
    /opt/webex/jre/lib/i386/libjawt.so \
    /opt/webex/jre/lib/i386/libnpjp2.so \

Install the libraries required for Webex to run

sudo apt-get install \
    libpangoxft-1.0-0:i386 \
    libxft2:i386 \
    libpangox-1.0-0:i386 \
    libxmu6:i386 \
    libxv1:i386 \

Create a Firefox launch script

cat << 'EOF' | sudo tee /opt/webex/firefox.sh

export ENV_HOME=/opt/webex
export FIREFOX_HOME=$ENV_HOME/firefox
export MOZ_PLUGIN_PATH=$ENV_HOME/firefox/plugins
export JAVA_HOME=$ENV_HOME/jre
export PATH=$JAVA_HOME/bin:$PATH


$FIREFOX_HOME/firefox --no-remote -P

This script will start a new instance of Firefox with the ProfileManager. Choose an existing Firefox profile or create a new one.

You might want to specify a specific profile to start with. Just add the profile name after the -P flag.

Don't forget to make the script executable with sudo chmod a+x /opt/webex/firefox.sh

You might want to create a symlink, a la: sudo ln -s /opt/webex/firefox.sh /usr/local/bin/firefox-i386

Start a Webex session

Launch the script and join a Webex session.

If webex.com sends you a jnlp file and Firefox asks what to do with it, just download it. Further, in the Firefox Preferences > Applications, set the action for JNLP files: they should be opened with javaws (Java Web Start) which can be found in /opt/webex/jre/bin/javaws

(Optional) Install the missing libraries required by Webex Find out what required libraries are be missing (note that the session number may be different):

ldd ~/.webex/T30_MC/*.so | grep "not found"

You can use http://packages.ubuntu.com/ to find out which packages contain the libraries.

It is OK to have libjawt.so absent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.