13

I have wicd, hplib and psensor installed. But they all always a run at startup in KDE environment. How can I stop them running at startup?

  • Did you check systemsettings -> startup & shutdown -> autostart ? What version of Ubuntu do you use? – Ruslan Gerasimov Jun 25 '14 at 6:56
  • There's no link for these apps in autostart. – user69453 Jun 25 '14 at 6:58
  • There is an autostart module in Kubuntu (KDE), I believe the startup applications and programs should be added/removed from startup via the "advanced" tab in that module. The system settings in Kubuntu should be called KDE control center. – RCF Jun 25 '14 at 7:08
22

KDE provides a wonderful tool in systemsettings ("Startup and Shutdown" -> "Autostart") for managing your personal autostart services (in either of the .kde directories) however it doesn't cover systemwide autostart scripts provided by your distribution packages, or created by the gnome apps.

Sometimes however it can be useful to override your distribution autostart preferences, for example I don't like having the printer-applet running as I don't own a printer, but it seems a shame to uninstall it in case I need it.

The correct way to disable a package installed is actually to copy it to your personal autostart folder. Anything of the same name in ~/.kde/share/autostart and/or /usr/share/autostart/ (also can be ~/.kde4/Autostart) overrides the .desktop file in the default installations. Once we have copied the .desktop file we can make changes. Add the following line to the .desktop file you have just copied:

Hidden=true 

KDE also restores your session when you log in, so if psensor is running when you log out, it will be started up again when you log in. To change that, just close psensor (i.e. actually quit the program, don't just close the window). If psensor is not running when you log out, it should not start up again when you log back in.

  • Ok, but I am using Kubuntu 15.04 and I cannot get rid of skype autostart at boot since there is not skype app to disable in in Autostart options. How do I remove skype startup from terminal? – KernelPanic Jun 18 '15 at 7:53
  • @MarkoFrelih Did you check in Skype->Options->General that Start Skype Minimised in system tray is unticked? – Ruslan Gerasimov Jun 18 '15 at 8:42
  • in there is no such option under Linux (at least I cannot find it), since the last version available from Skype's website is 4.3, which is veryy old. – KernelPanic Jun 18 '15 at 9:15
  • Can't find .desktop file... @KernelPanic did you find out how to stop Skype from running at startup? – Mr.WorshipMe Dec 1 '15 at 23:52
  • 1
    Since KDE 5.x, this stuff lives in ~/.config/autostart/. You can also put your own scripts in ~/.config/autostart-scripts/. See also: docs.kde.org/trunk5/en/kde-workspace/kcontrol/autostart – Joe Sep 7 '18 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.