6

I am using Ubuntu 14.04 LTS and trying to unzip rpm file like

sudo alien --scripts -d oracle-xe-11.2.0-1.0.x86_64.rpm

I am getting like

error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /root/.rpmdb

Any one please help me

2 Answers 2

12

This has nothing to do with Oracle. Remove ~/.rpmdb/ directory and try again.

1

I went to the Oracle web site, and then poked about google for a good bit of time on this one. Frankly, I think you are looking at a very difficult installation, and you will need to spend a lot of quality time with your search engine to make this work. Oracle does not love Ubuntu very much!

The easiest way to implement Oracle that I found, is to run Oracle Linux, a RedHat derivative(?) as a VM in VirtualBox, at which point Oracle Express should install seamlessly.

In fact to make it even easier, you can download a pre-installed VM with a relatively current version of Oracle Linux, and Oracle Express 12g at these pages. The "Service Delivery Platform VM" looks like a good bet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.