1

This question already has an answer here:

I'm preparing for a trip where I can't bring my desktop, so I recently broke out my trusty old laptop (Dell Latitude E4300) to get it ready for the trip. Previously, I had Ubuntu 12.04 LTS on the machine and there were no problems with wifi or the computer in general. My original problem came when I tried to upgrade to Ubuntu 14.04, which failed halfway through and long story short: I couldn't get it to work. I then installed Lubuntu 14.04 (It's a moderately old laptop and I had never tried Lubuntu, so why not) and it's going great, except, I can't connect to my wifi and since this will be my only method of access on my vacation, I really need to fix it. I'm kinda at a cross roads since I've never had this problem with this laptop. Any help would be great.

The output of "lspci -nvn | grep -i net" Says the wifi card is a "Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller [14e4:432b] (rev 01)"

I have looked at many other similar questions, but they're all very old and none have helped. Sorry if you guys get this a lot.

EDIT: Here is the link to the requested diagnostics (See comment by user "wild man"_ http://pastebin.ubuntu.com/7700888/

marked as duplicate by Pilot6, Eric Carvalho, edwinksl, Kevin Bowen, Wild Man Aug 14 '16 at 6:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

Please temporarily connect the ethernet and with a working connection, do:

sudo apt-get install linux-firmware-nonfree

Reboot. If it is not working, post the entirety of the wireless script again.

EDIT: Jul 18 '17: As is the case with many answers here, this and most answers that are three or more years old are probably obsolete. In fact, today the correct package is firmware-b43-installer. There is no need to update and research Broadcom questions however, as the link in the duplicate is updated regularly as needed.

  • Apparently I'm not connected to a repo with that on it? I'm on ethernet and the package can't download because it can't be found Edit: Never mind, ran update and it found it. – lijrobert Jun 25 '14 at 15:11
  • For future reference, such software could belong to a repository that hasn't been enabled, such as multiverse and universe repository, or restricted. One can always enable these repositories via System Settings -> Software – Sergiy Kolodyazhnyy Aug 10 '16 at 9:57
  • 1
    This answer is obsolete. Now it is sudo apt-get install firmware-b43-installer – Pilot6 Aug 10 '16 at 13:53
  • Yes, indeed. Yesterday is history; tomorrow is a mystery. – chili555 Aug 10 '16 at 14:21
  • @chili555, I (and not only) would appreciate if you include in your answer the comment of Pilot6 for lubuntu 16.04... – koleygr Jul 18 '17 at 10:22
0

Have you tried opening "Additional Drivers" to see if there was a non-free driver available? If so try enabling that. I know this has worked for me on friends' laptops with Broadcom wireless cards before but I'm not sure if any of them had the same model you have. It's worth a shot, though.

If that doesn't work I would just stick with 12.04 for the time being simply so you have something that will function while you are away. Once you get back you can then start to experiment with fixing this Broadcom driver. It would be a shame to be able to hack up a fix only to have it break mid-way through the vacation.

-2

There's nothing wrong with 12.04.

If you had no issues with it go to http://cdimage.ubuntu.com/ and download a 12.04 ISO and install it.

  • But it's 2 years old :) and sometimes has some problems with Unity dash, as I remember. – NoBugs Jun 25 '14 at 5:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.