2

I have recently got hold of a new laptop running Ubuntu 14.04.

I tried to set up netflix using the pipelight package as I had done previously on my old laptop using Mint 14. Now however, despite having followed the installation and configuration instructions given for Ubuntu and installing and configuring User Agent Overrider on Firefox.

However, I'm still confronted with a message telling me I need to install the silverlight plugin when I try to watch anything on Netflix.

I have also troubleshooted as described on their FAQ and everything seems fine. I've trawled the internet for solutions, but can't seem to work it out.

Does anyone please have any suggestions as to why this might be and how I might fix it?

  • Did you run sudo pipelight-plugin --enable silverlight? – hal7df Jun 25 '14 at 3:55
  • Did you also set your Firefox User Agent Overrider to "Windows/Firefox 29?...and restart Firefox? – RCF Jun 25 '14 at 7:01
  • Thanks for answering so fast. Yeah, I did both of those things, I still get the incompatibility message when I switch Agent Overrider back to the Linux/Firefox29 setting, and the request to install silverlight when I use the Windows/Firefox29 setting. The only thing unsual about my installation was that I has accidentally selected not to install the ms core fonts, but I then installed those separately and the output of pipelight-plugin --system-check tells me the Fonts test is now passed, where it wasn't before. Do you guys have any other ideas? Thanks again for your comments. – bugjunkie Jun 25 '14 at 11:12
  • it only worked here with netflix-desktop from here. – Aquarius Power Aug 28 '14 at 22:53
  • possible duplicate of Is there a way to stream Netflix? – Mateo Sep 25 '14 at 18:01
1

I ran into this exact same problem on an older system, and thought that Netflix had changed something, but it was fixed by following hal7df's suggestions to:

 sudo pipelight-plugin --enable silverlight

Which downloaded the newest Silverlight, 5.1, and worked immediately. You might try double checking your install and rerunning those commands, just to be sure. I've also seen issues with the apt keys used for pipelight from time to time. Good luck!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.