4

I installed kubuntu-desktop via software centre but now everything is messed up in unity. As if the theme was changed but it's still "Ambiance" (the default). It even affects LXDE. For example...

  • Icon theme was changed to some other icon theme. Icons
  • Some fonts are different like In Google chrome, fonts like "Hardware Insights Juju..." aren't supposed to be that thin. Also in the indicators' menus; you see it's not even readable and the icon for the language (that looks like this --> [EN] ) is missing. Fonts
  • Notifications look like kubuntu's.
  • Double click to maximize doesn't work any more. It glitches in a weird way. Also there's a bug when switching workspaces but it's hard for me to explain.
  • Grub has a black background now.
  • after grub, there should appear "Ubuntu" with 5 dots below it. Instead appears "Kubuntu" flashing.
  • Who knows what else would I discover :/

What I want: A clean Unity desktop. A brand new one. And I want grub back to its old look. I tried to reinstall unity but it doesn't work. It only uninstalls a few megabytes leaving behind loads of dependencies which really matter and nothing gets fixed. I like kde as long as it doesn't mess things up. Can someone please tell me how to reinstall it or at least any workaround to all those problems though I really really don't prefer this.

I've tried this Q&A but no joy:

I've tried to reset my Unity configuration using this Q&A but this also didnt work:

  • Or search this site for remove kubuntu – Panther Jun 24 '14 at 23:01
  • I have edited out some impolite comments and nominated the question for reopening. I feel your pain, restoring everything back after a *-desktop install is possible but not usually easy. I hope that you find an answer. – Javier Rivera Jun 26 '14 at 12:22
  • Not an answer, but IMHO reinstalling should be easier. – Javier Rivera Jun 26 '14 at 12:23
  • ahhh I'm sorry I got mad guys I'm really sorry. Specially to you @bodhi.zazen I'm so so so sorry and I was pretty rude. I just need to fix my system quick and I haven't already :'( – Mina Michael Jun 26 '14 at 14:18
  • @JavierRivera I thought about reinstalling but this would take even more time; I have to reinstall my programs and would risk losing files. thanks for the advice – Mina Michael Jun 26 '14 at 14:20
1

I know this answer probably comes too late but I was just using these answers to find out the solution to the same issue and ran into this:

Clean removal of KDE 4

From there I found this website with a one-step-shopping solution for clean ubuntu restoration:

http://www.psychocats.net/ubuntucat/tag/pure-ubuntu/

My version was 14.04 and that command works perfectly for me. It removed some software I installed on ubuntu before the installation of KDE but I wouldn't mind reinstall these software since now I have a pure(at least as far as what I see) ubuntu to work on.

0

I had a similar problem: after installing kubuntu-desktop, many of my unity settings were seriously messed up. I moved all the config files, and restored them from backup. In my home directory:

mv .gnome .XXgnome
mv .gnome2 .XXgnome2
mv .config .XXconfig
mv .local .XXlocal
cd /my/backup/location
cp -rp .gnome .gnome2 .config .local ~

I didn't bother to find out which of these kde had infected. After a logout/login cycle, most of my unity functions are back, can I can be productive again. The GUI widgets in most applications look kde-ish, but at least now the system fonts make sense again. I can't tell if this is a qt or gtk configuration issue.

None of this fixed my problem that I could not change the desktop image, even after trying with shotwell, gsettings, the unity settings panel... What eventually solved that part was turning on "icons on desktop" in the gnome tweak tool. It doesn't matter that I have all the icons turned off, "icons on desktop" has to be enabled, or nothing will change the desktop image.

0

Same problem here, last night installed kubuntu-desktop on my Ubuntu 14.04 and the language icon dissapeared and menuitems style was changed. Things that I tried:

  • System config theme setted again to Ambiance, improved some things.
  • Resetting unity: unity-tweak-tool --reset-unity (No visible change).
  • Edit the file located at: $HOME/.config/gtk-3.0/settings.ini (this was the final solution).

The changes made to settings.ini:

gtk-theme-name=Ambiance (changed from value okygen-gtk) gtk-icon-theme-name=Ambiance (changed from value oxygen)

Finally login into Unity again and the problem was solved. The best part is that the change is persistent, so Unity and KDE keeps their respectives styles.

  • This fixed unity and the icons, but chrome and all file dialogs were still kde-themed. This answer fixed those: askubuntu.com/a/225652 – Kevin May 19 '15 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.