I have a dual boot system with Windows 7 and Kubuntu 13.10 on two separate physical disks (SSD).

I have two partitions for Ubuntu: an unencrypted "/boot" and an encrypted "/".

Everything was working as expected (booting on both OS) until I unfortunately unplugged the Windows disk and rebooted with the Ubuntu Disk alone. I had a "bootmgr is missing" message. I immediately replugged the Windows disk but still had the same message.

So I tried to "boot-repair" and succeeded in getting the Grub menu back to choose between Windows and Ubuntu again. Windows boot is working but when trying to boot on Ubuntu the passphrase for the encrypted disk just after the Grub menu is consistantly failing. Exact message being: "cryptsetup: cryptsetup failed, bas password or options?"

When launching a ubuntu installation CD I'm able to connect to the encrypted disk (the passphrase is working from Dolphin file manager and I can access the files) so the encrypted volume is still accessible even though I'm not able to launch Ubuntu on it.

I guess that when I unplugged the Windows disk the BIOS switched to the Ubuntu disk as primary boot device and failed to find the "bootmgr". Hence the "Bootmgr is missing" message. Later when I ran "boot-repair" it overwrote my initial Grub files and I lost some information to decrypt the disk from Grub (?).

Now I'm not able to boot on Ubuntu anymore. :(

I tried to run "boot-repair" a second time with only the Ubuntu disk (mono boot) to see if any progress but I still have the same issue with the passphrase step.

Any Idea how I can get my system working back? I browsed the web for hours with no answer to this specific issue.


I think you could have solved this if you kept a copy of master boot record. So that you can copy it where it needed to be.

  • I'm learning Linux... painfully. :-) Don't even know if Grub is installed in the MBR or not in my configuration (I let the installation wizard do everything for me blindly) – Nitseg Jun 25 '14 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.