How can I install Canon LBP2900B on Ubuntu 14.04 LTS ? I tried the method for the installation of LBP2900, but it didn't work.

I tried installing the CanonCaptDrv190 as outlined in the Community wiki and answers #1 by Alvar. #2 by SarveshM @ How to install Canon LBP2900 printer in ubuntu 12.10 but neither approach worked for me. The printer is switched on and has pages in tray and connected through USB.

EDIT: I followed the Ubuntu 13.10 installation method of Community Help Wiki again. Now I get this

On command 4 (sudo update-rc.d ccpd defaults) -

update-rc.d: warning /etc/init.d/ccpd missing LSB information

update-rc.d: seehttp://wiki.debian.org/LSBInitScripts

System start/stop links for /etc/init.d/ccpd already exist.

On seeing captstatusui for LBP2900, I get -

Message : No Specified Printer

In the below box I get - Check the (Printer asterix,asterix,asterix (the symbol)) of /etc/ccpd.conf

I tried your method, Elder Geek but it didn't work.

Any more ideas?

Regards, Andy

  • AFAIK, the 2900B is black and the 2900 is white. There is no difference in drivers that I can find. We will be more able to help you if you edit your question to include which method of installation you tried and how it didn't work (the error messages that you may find confusing, we actually need). thank you!
    – Elder Geek
    Jun 24 '14 at 14:59
  • I am sorry for replying late. I am talking about the CanonCaptDrv190 in Community Wiki.Even if I try to print a test page after a restart, the printer status show 'Idle'. Do you have a n idea why is this so?
    – Andy_519
    Jun 27 '14 at 14:28
  • askubuntu.com/questions/232645/… I tried this too.
    – Andy_519
    Jun 27 '14 at 14:34
  • which of the 3 answers at askubuntu.com/questions/232645/… did you try?
    – Elder Geek
    Jun 27 '14 at 14:42
  • I've edited your question to include the info you provided in the comments. In future please do this yourself and provide as much detail as possible. Things that don't seem important to you may be critical to us helping you solve this problem. Thank you!
    – Elder Geek
    Jun 27 '14 at 14:44

I've got the LBP2900 working in Ubuntu 14.04.

  1. Download Linux capt driver version 2.60

  2. Extract it into download folder and opened the folder for 32 bit, as my installation is 32 bit:

    downloads → linux capt... → 32 bit driver → debian

  3. After that double click on the files, the Ubuntu software center opens and asks to install it. Install both the files one by one, second one first.

  4. Install the following additional packages from the Ubuntu software center: portreserve, gsfonts, gsfonts-other, gsfonts-X11.

  5. Restart the printer

    service cups restart
  6. Add your printer and start the printer daemon:

    sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59787 -E 
    sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0
    sudo service ccpd start
    sudo service ccpd status
  7. Check the function of the printer:

    captstatusui -P LBP2900

    this will popup a new window. If the message is "Ready to print", you are done. If the message is error of no printer connected etc., restart the operating system and repeat the steps five to seven, and it will start.

Sometimes it may stop working after restart, then run

sudo service ccpd restart 

and try again.

It was a joyful experience for me to get my lbp2900b working in Ubuntu 14.04, otherwise i will have to make double boot to Windows for just printing.

  • Thanx man......Finally found a solution that works...Its working like charm. It works 100%. The most important command is the first line of step 6 (ccp://localhost:59787 ). Most of the solutions you find will have this command missing which is causing the real problem. Thanks a lot man. Nov 1 '15 at 19:28
  • For me /dev/usb/lp0 does't exists, I changed to /dev/usb/lp1
    – fangxing
    Jan 4 '18 at 14:11

Open printers:


Click Add

Add printer

Choose your printer from the list or enter the URI (the list should populate with detected printers provided you've followed the instructions in the community wiki about setting up CUPS

New printer

This is what I get as I print over the network:


Next you'll choose the driver to use for me Brother is recommended, yours will be Canon.

If you have a PPD file you can choose it here, if not, try to choose your printer from the database by selecting Canon here


If you don't find your model listed here hit the back button and try searching for a driver to download above.


Once you've found your model listed, select it and move forward

You'll be asked to identify your printer here:


do so and then click apply. Now print a test page to insure everything is working properly:

test page

If it prints congratulations, your done! If not, right click on the printer and insure that Enabled is checked (it should be)


If you right click on the printer and choose properties you'll get something like this (your URI and driver will be different): props

You should insure that these settings make sense if you can't print. If you have the wrong driver and everything else is correct you'll usually get something from the printer (garbled output, page feed, etc.)

  • Well, I used the correct one (2.60-1). As the Device URI I get ccp://localhost:59687. It sits quiet as if it is switched off :-(
    – Andy_519
    Jun 27 '14 at 17:16
  • 1: It is directly connected to the PC on which I want to print 2: I selected LBP2900 as model
    – Andy_519
    Jun 27 '14 at 17:20
  • Have you setup CUPS?
    – Elder Geek
    Jun 27 '14 at 17:24
  • Please review help.ubuntu.com/12.04/serverguide/cups.html
    – Elder Geek
    Jun 27 '14 at 17:25
  • Yes I have the CUPS Core Library.
    – Andy_519
    Jun 27 '14 at 17:45

Try with installing printer-driver-cjet package, which is the common driver for Cannon LBP printers:

sudo apt-get install printer-driver-cjet
  • Yeah I did that now. What do I do next?
    – Andy_519
    Jun 27 '14 at 14:30
  • Open the printer with the application system-config-printer-gnome
    – user308564
    Jun 27 '14 at 15:01
  • How do you do that exactly ?
    – Andy_519
    Jun 27 '14 at 15:18
  • Type system-config-printer-gnome in dash. then that "Printer" icon will appear. open the application. then select the printer.
    – user308564
    Jun 27 '14 at 15:56
  • Ok I got it... Thanks but no response from printer
    – Andy_519
    Jun 27 '14 at 17:18

Installing Canon LBP2900 / LBP2900B – Ubuntu 14+

Note: Improved clarity of answer; Based on one of the above answers; thanks to that answer; I have "edubuntu@edubuntu-HCL-Desktop".

  1. Download Linux capt driver version 2.70 for Linux from Canon web site

  2. Extract it into downloads folder and open the folder for 32/64 bit: downloads → Linux capt... → 32/64 bit driver → Debian → you will find two files.

    • cndrvcups-capt_2.70-1_i386[or-amd64].deb
    • cndrvcups-common_3.20-1_i386[or-amd64].deb
  3. Turn the printer on

  4. Double click on the files, the Ubuntu software center opens and asks to install it. Install both the files one by one, second one first.

  5. Install the following additional packages from the Ubuntu software center: portreserve gsfonts gsfonts-other gsfonts-X11 (may be already installed, if not then install them).

  6. Adding your printer and start the printer daemon with the following commands from a Terminal (open with Ctrl+Alt+T):

    • service cups restart

    (usually display comes as follows)

    stop: Unknown job: cups
    start: Unknown job: cups
    • sudo /usr/sbin/lpadmin -p LBP2900 -m CNCUPSLBP2900CAPTK.ppd -v ccp://localhost:59787 -E

      (usually display comes as follows)

      [sudo] password for edubuntu: enter password if exists

    • sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

    (usually display comes as follows)

     CUPS_ConfigPath = /etc/cups/
     LOG Path        = None
     UI Port         = 59787
     Entry Num : Spooler : Backend : FIFO path         : Device Path    : Status 
     ---------- --------- --------- ------------------- ---------------- -------
     [0]       : LBP2900 : ccp     : //localhost:59787 : /dev/usb/lp0   : New!!
    • sudo service ccpd start

    (usually display comes as follows)

    Starting /usr/sbin/ccpd: .
    • sudo service ccpd status

    (usually display comes as follows)

    /usr/sbin/ccpd: 6937 6936
    captstatusui -P LBP2900
  7. This will pop up a new window. In that If the message is “Ready to print”; then you are ready with the printer LBP 2900. If the message is “error” or “no printer connected” etc then restart the operating system and repeat all the steps at Terminal, and it will start the printer LBP 2900. Sometimes it may stop working after restart, then do this:

    sudo service ccpd restart 

If this is the display comes as follows:

(captstatusui:6949): GLib-CRITICAL **: Source ID 13 was not found when attempting to remove it
  1. Then, switch off and On the printer and do at Terminal again:

    captstatusui -P LBP2900

You are ready with the printer LBP 2900 / LBP 2900B.

  • Welcome to Ask Ubuntu! Please do not post duplicate answers on different questions. It just creates more work for the moderators. If the questions are so similar that the same answer works on each, then the later of the two is likely a duplicate and should be flagged as such. Aug 13 '16 at 13:26
  • 1
    it gives an error : Check the DevicePath of /etc/ccpd.conf on ubuntu 14.04, 64-bit Aug 13 '17 at 14:43

One comment , which may help someone in need, please use 32 bit drivers and corresponding instructions (by Sameer/Subbaya), EVEN for a 64 bit machine.

Also , before running the command below , please do check if printer was really present at usb0 (or lp0) : (otherwise use appropriate usb port in it)

sudo /usr/sbin/ccpdadmin -p LBP2900 -o /dev/usb/lp0

(Edwin's answer here : How to make Canon LBP2900B work on Ubuntu 16.04 LTS? )

Not the answer you're looking for? Browse other questions tagged or ask your own question.