4

I've searched beforehand and the only suggestion I've found is this one but it doesn't work, at least not on my system (Ubuntu Unity 14.04 x64).

I need to disable the touch on my WACOM Bamboo Manga CTH-470 tablet so only the pen tip and eraser are recognized and not my hand when I accidentally touch it.

I know of this temporary solution:

xsetwacom --list

to list the output of the tablet (example)

inoki@innerdistance-Satellite-L650:~$ xsetwacom --list Wacom Bamboo 16FG 4x5 Pen stylus id: 11 type: STYLUS
Wacom Bamboo 16FG 4x5 Finger touch id: 12 type: TOUCH
Wacom Bamboo 16FG 4x5 Pen eraser id: 16 type: ERASER
Wacom Bamboo 16FG 4x5 Finger pad id: 17 type: PAD

then

xsetwacom --set # touch off

Using

inoki@innerdistance-Satellite-L650:~$ xsetwacom --list | grep TOUCH | cut -d ' ' -f 8 TOUCH inoki@innerdistance-Satellite-L650:~$

has shown only the "TOUCH" word exactly as above.

I need to make it permanent, so I don't have to insert the command every time I want to work with my tablet.

  • Add the command to your autostart configuration. – hal7df Jun 25 '14 at 4:22
  • That's a no go, since when the tablet is plugged out and plugged back in it changes numerical values for the touch option, for instance at first the identifier for touch can be 11, after re-plugging it it can be 13. – Patrik Jun 25 '14 at 7:34
  • Could you maybe provide a sample of the output of xsetwacom --list? – hal7df Jun 25 '14 at 20:05
  • @hal7df sure, see below: xsetwacom --list Wacom Bamboo 16FG 4x5 Finger touch id: 10type: TOUCH Wacom Bamboo 16FG 4x5 Finger pad id: 11 type: PAD Wacom Bamboo 16FG 4x5 Pen stylus id: 12 type: STYLUS Wacom Bamboo 16FG 4x5 Pen eraser id: 16 type: ERASER – Patrik Jun 26 '14 at 4:17
  • Apologies for the formatting, but couldn't get it aligned. The numbers for the values vary each time the tablet is being plugged in. – Patrik Jun 26 '14 at 4:25
6

in my case worked this:

xsetwacom -v --set 'Wacom Intuos Pro M (WL) Finger touch' gesture off

test

xsetwacom -v --set 'Wacom Bamboo 16FG 4x5 Finger touch' gesture off
| improve this answer | |
  • 2
    If you, like me, experience that while this command disables gesture but not tapping (i.e. finger 'clicks'), run the command again but then replace 'gesture' with 'touch'. So in my case: xsetwacom -v --set 'Wacom Intuos PT S Finger touch' touch off – iGadget Sep 30 '15 at 14:23
  • I edited this older thread to show how to use the scripts on the tablet's buttons: askubuntu.com/a/118466/53256 . In this case, having a one-line command for toggling makes sense. – Maxweel Dec 29 '16 at 21:24
5

Rather than rely on fixed character positions and cut, you could use sed instead, like this:

xsetwacom --set `xsetwacom --list | grep TOUCH | sed -r "s/.*id: *([0-9]*).*/\1/"` touch off
| improve this answer | |
  • Not really. The by me marked solution works like a charm and, most importantly, it is memorable. Your suggested method might work, but can easily be forgotten or mistyped. The working method can be applied by just creating a launcher and triggered each time the tablet is used. Thanks for the effort though. – Patrik Jun 5 '15 at 17:34
  • @Patrik This solution can be pasted into a script just as easily, and is generic, so it will work for other wacom tablets that have a 'TOUCH' device. – Timtro Feb 16 '16 at 17:31
1

First off, you still need to add the new command to your autostart configuration so that it's disabled to start with:

xsetwacom --set `xsetwacom --list | grep TOUCH | cut -c 40-42` touch off

Then try putting the following into a new file: /etc/pm/power.d/99_touchdisable:

#!/bin/bash

ac_power ()
{
    xsetwacom --set `xsetwacom --list | grep TOUCH | cut -c 40-42` touch off
}

battery_power ()
{
    xsetwacom --set `xsetwacom --list | grep TOUCH | cut -c 40-42` touch off
}

Then run sudo chmod 755 /etc/pm/power.d/99_touchdisable

Restart your tablet and try unplugging/plugging in your tablet.

If it doesn't work, check to see if you have different power profiles enabled. If it still isn't working, run sudo apt-get install pm-utils and try running sudo pm-powersave <true/false> to get it to run the script.

| improve this answer | |
  • Followed your instructions, restarted the computer, re-plugged the tablet but still it enables the touch by default. – Patrik Jun 27 '14 at 13:25
  • 1
    I doubt it'll do much but try removing the exec keyword (I'm not exactly the world's best scripter...) – hal7df Jul 2 '14 at 18:37
  • Also, did it disable touch at startup, at least? – hal7df Jul 2 '14 at 18:38
  • nope, nothing changed. – Patrik Jul 2 '14 at 19:07
  • 1
    Okay, new command. See if this command gets the ID number by itself: xsetwacom --list | grep TOUCH | cut -c 41,42 – hal7df Jul 7 '14 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.