34

I have Ubuntu running in VirtualBox on a Windows 7 host machine. How can I make my built-in laptop camera work with it?

30

This is possible, but requires a few steps to get working properly:

  1. Make sure the virtual machine is not running and your webcam is not being used.
  2. Bring up the main VBox window and in the details tab for your Win7 machine click USB.
  3. Make sure "Enable USB Controller" is selected. Also make sure that "Enable USB 2.0 (EHCI) Controller" is selected too.
  4. Click the "Add filter from device" button (the cable with the '+' icon).
  5. Select your device from the list.
  6. Now click OK and start your VM.

This will cause the device to show up as if it were plugged into the VM. From there, you should be able to use it or install drivers if necessary.

  • 4
    Please note that this also requires the package from virtualbox.org, if I remember correctly. Here are the packages: i386 | x64 – Nathan Osman Sep 30 '10 at 1:18
  • 1
    I don't think the version in the official repos. has support for USB devices. – Nathan Osman Sep 30 '10 at 1:19
  • 1
    @Shubhkarman: Are you sure that Ubuntu is detecting your camera? Can you use it in other applications? – Nathan Osman Sep 30 '10 at 5:24
  • 1
    @George Nope. This is the the whole point of this question too. – User Oct 1 '10 at 2:04
  • 2
    @GeorgeMauer: A lot of built-in cameras are connected internally over the USB bus. – Nathan Osman Oct 10 '12 at 17:55
12

The same answer of @Nathan Osman , However , it required to belong to vboxusers group to be able to see all devices on adding one.

sudo usermod -a -G vboxusers $(whoami)

Logout & login again , check if your vboxusers displays in this command :

groups
  • 3
    usermode: group 'vboxusers' does not exist. What now? – andrecarlucci Nov 18 '16 at 1:42
  • Worked for me (with answer of Natha Osman). – Artur Barseghyan Oct 24 '17 at 9:48
4

Probably, you should download and install VirtualBox extension pack which will supported USB 2.0 and USB 3.0 devices.

I faced the same issue earlier and I got it solved by installing this extension pack.

  1. Install the VirtualBox extension pack
  2. Restart both host and guest system.

Go to Settings --> USB
select USB 2.0 (EHCI) controller
Look in Add new filters.
Now your webcam appears in the list. Add those USB Filters.

Note: My Host is Windows 10 and Virtual Os is Ubuntu 16.04

4

Many built-in cameras will not appear as USB devices.

In this case you need to install the VirtualBox Extension Pack and possibly the Guest Additions (not sure about it).

Then restart the VM and in the top menu Devices there should be a new submenu Webcams. Enable your webcam from there and it should become available in the VM.

  • I know the question is about Windows as host but for people on Ubuntu with the same problem: The extension pack can be installed via sudo apt install virtualbox-ext-pack. After this I had to restart virtualbox and then the webcam showed up in the devices menu. – luator Aug 23 at 7:28
0

I followed all the steps from Rajes_Saladi. Need to do one additional step from steps mentioned:

  • After booting the guest Ubuntu OS go to menu Devices -> Webcams -> {Tick the Integrated webamera option}
  • Run the in built cheese application to verify weather Camera is funcional

Note: I am using integrated webcam of laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.