0

My new and recent setup of Ubuntu 14.04 on a Dell Inspiron 7437 (laptop) shows some peculiar behavior in terms of the battery indicator:

If the laptop is connected to its power supply, the indicator works fine and shows the progress of charging and also discharging after I disconnect the power supply. However, if I then restart the laptop on battery, there is no battery indicator anymore (which is really annoying on a laptop...). It will return though once I connect it again to the power supply...

I have already reinstalled the service and tried several other fixes (seems to be a common problem...) from the web but so far nothing has really worked yet.

  • All Settings -> Power: what is the setting for "Show battery status in the menu bar"? – Jakke Jun 24 '14 at 0:54
1

Here is a step by step process based on previous entries that helped me. Open a terminal session and use the following command;

gksudo gedit /etc/default/grub

in gedit change the following entry from

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

Then save and close your gedit session. Next in your terminal session run

sudo update-grub

This will rebuild your grub menu. Reboot and look for your battery icon!

For me this didn't work until I updated my bios from version A05 to A13. If you also need to update your bios you can use unetbootin and freedos to load your .exe in dos!

| improve this answer | |
0

Add acpi_osi=Linux to grub boot options

https://bugs.launchpad.net/ubuntu/+source/upower/+bug/1088146/comments/13

| improve this answer | |
  • This answer is incomplete. Please add more info and provide the link for reference. – Parto Sep 7 '14 at 15:43
0

I've tried about everything but have given up hope. The only workaround I have is to have 2 versions of /etc/default/grub , one, for battery status, with

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux"

and the other for touchpad with

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

They appear mutually exclusive - i.e. either I have battery status with no touchpad, or vice versa.

By the way - I'm using Ubuntu 16.04

| improve this answer | |
  • So do you edit the file and sudo update-grub and reboot each time you want to switch? Do you have the same device? You could clarify somewhat. – Zanna May 14 '17 at 11:13
  • Yes indeed I do that Sudo and reboot each time. It is the same ACER Aspire-ES1-512 I had before but updated from 15.0 to 16.04 L TS, 64 bit. Intel® Pentium(R) CPU N3540 @ 2.16GHz . – Hugh May 14 '17 at 14:58
  • so your device is not the same as the one mentioned by OP - so there is no way of knowing whether this might work for them – Zanna May 14 '17 at 15:04
  • I changed to 16.04 at your suggestion. You implied that if I did you would be able to help. So far I've no evidence of that. And by the way I didn't know how to 'ping' you. – Hugh May 14 '17 at 15:55
  • you ping someone like this @Zanna... you must be talking about a question you asked? Or did you not intend to post an answer to this question? – Zanna May 14 '17 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.