21

How to change Unity 3D to 2D on Ubuntu 14.04? And, will I get any improvements in performance if do that? What software utilities will I lose if I switch to from Unity 3D to 2D?

12

Unity 2D is not available in Ubuntu 14.04, thus you can't switch. The packages for unity-2d in 14.04 are just transitional dummy packages. They don't contain any files but depend on Unity 3D.

7

Cannot promise performance boost as such, but see if this can be of any help (from https://sites.google.com/site/easylinuxtipsproject/speed ).

Disable the visual effects: switch to a 2D desktop environment

  1. By default, when your video card can handle it, the 3D visual effects are enabled. However, these may cause malfunctions or sluggish performance. You can disable them by switching to a 2D desktop environment.

There are several options for this.

My personal favourite is a switch to the Xubuntu desktop. But there's another option as well:

a. First, install gnome-session-fallback:

Click on the grey Ubuntu logo (Dash home). Query: terminal. Click on Terminal. Type (use copy/paste): sudo apt-get install gnome-session-fallback

Press Enter. When prompted, type your password. Your password will remain entirely invisible, not even dots will show, this is normal. Press Enter again.

b. Log out. In the login window, click on the Ubuntu logo next to your user name:

Then click on GNOME Flashback (Metacity). Note: don't select GNOME Flashback (Compiz), because that also has 3D effects, and you want to get rid of those.

c. Log in again.

  • This fixed all my problems well done. – Edward Oct 5 '15 at 11:34
  • 1
    On 16.04 the package is called gnome-session-flashback – RyanTM May 24 '16 at 15:58
3

Unity 2D is not available in Ubuntu 14.04.

However http://lubuntu.net/ is a lightweight flavor of Ubuntu, currently available at revision 14.04. It will run far faster than even Unity 2D.

  • You could also simply install another display manager, in this case lubuntu-common, I think. (lubuntu-desktop includes all out-of-the-box programs of Lubuntu) – Peter Nerlich Apr 17 '15 at 14:16
2

Unity 2D package is no longer available because there's an identical alternative to go around it without having to change the shell.

  1. Install compizconfig-settings-manager

    sudo apt-get install compizconfig-settings-manager

  2. Open compizconfig-settings-manager

  3. Click "Preferences"

  4. Under Profile switch it from "unity" to "unity-lowgfx"

Enjoy =]

  • 1
    Great hint, but the profile is missing on 16.04.1 LTS. Instead it's done using the "Enable Low Graphics Mode" option in the "Ubuntu Unity Plugin" configuration. – tlwhitec Feb 1 '17 at 13:28
  • In 17.10 the profile was present, while the optino mentioned by tlwhitec was not. This hint freed up about 180MB of memory; not a lot but something and apparently enough to make my machine subjectively usable again. – dremodaris Jun 29 '18 at 7:32
0

I installed LUbuntu, then in terminal:

sudo apt-get install unity-2d

Reboot my system, login in Lxsession and in terminal

unity && > /dev/null

Finaly I've got unity 2D in 14.04 LTS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.