1

I created a custom shortcut in Keyboard->Shortcuts and set it opens qalculator app.

Then I assigned to it the keyboard Calculator key. Ubuntu asked me if I want to replace the original app and I confirmed it.

But now, nothing happens when I press the keyboard calculator key! I even changed the command from qalculator to /usr/bin/qalculate or /usr/share/qalculate, but the app does not open at all.

0

This seems to be a bug in unity-settings-daemon. I have filed it with them: https://bugs.launchpad.net/ubuntu/+source/unity-settings-daemon/+bug/1399132

As a workaround you can edit the settings manually with dconf Editor. To install it run sudo apt-get install dconf-tools.

You can find your custom shortcut under org.gnome.settings-daemon.plugins.media-keys.custom-keybindings and change the binding value to XF86Calculator

Refer to https://wiki.ubuntu.com/Keybindings

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.