8

I am using Kubuntu 14.04.

I had to completely remove ibus because not only it bugged chromium, but also I do not need it at all.

Unfortunately, I have the feeling it is not completely disabled because I have warning messages in some application logs:

x@aspire6930g:~$ konsole
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
x@aspire6930g:~$ Bus::open: Connect ibus failed!
IBusInputContext::createInputContext: no connection to ibus-daemon 

As the ibus package no longer exists on my system, there is no ibus-daemon.

My question is : what additional step should I perform to tell the system that I do not use ibus ?

14
  1. Run qtconfig-qt4 → Interface tab
  2. Set Default Input Method to xim

If for some reasons didn't work, try using im-config:

  1. Check for available & default input systems:

    $ im-config -l
    ibus xim
    
    $ im-config -m
    default
    ibus
    ibus
    
  2. Set other one, xim is the standard for X server

    im-config -n xim
    
| improve this answer | |
  • 3
    Perfect ! It works fine. I had to install qt4-qtconfig which was not installed. – Larry Jun 23 '14 at 15:31
  • 1
    By the way, the Google Chromium ibus bug looks fixed now. I enabled ibus ok and it works fine. – Larry Sep 7 '14 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.