26

If you are using a high DPI Display with a resolution of 3200x1600 px you can adjust Unity with a System wide Menu and titlebar scaling But Firefox is not really ready for this: All pages and the Icons stay tiny.

multiplication of system font increase and browser font increase makes system controls (combobox, lists, drop down lists) extremely big on many websites, where the form elements are affected by the scaling two times, so all form elements are huge (4x).

emails in Thunderbird are displayed tiny, so you have to use Ctrl++ all the time

How can I adjust Firefox and Thunderbird, so everything will look normal?

  • Firefox is now supposed to pick up the scaling factor automatically. But somehow there's a bug bugzilla.mozilla.org/show_bug.cgi?id=1214470 that makes it round the value to the nearest integer, so one would still need to manually specify layout.css.devPixelsPerPx. – xji Jan 25 '18 at 18:18
40
  1. Install my Firefox-addon Zoom Menu Elements (or install this file from source on github).
    Alternative: you can manually open a new tab about:config in Firefox and search for layout.css.devPixelsPerPx set this value to 2 or 1.5 as you wish to adjust the size of the Firefox icons (source, bug report)

  2. Install the Firefox-addon Fix for zoomed default-font to fix some issues with huge form elements on some pages (for ex. the login on reddit.com, ... see this question )

  3. Pinch-to-zoom works out of the box (see here), for older versions the grab and drag addon for Firefox makes it possible to navigate the Internet by touch (disable it with the button grab-and-drag-button in the add-on-bar when using a mouse)

  4. Additionally, (but not needed) install the Firefox addon NoSquint or Default Fullzoomlevel and chose in settings: default full page zoom level 120%.

In Thunderbird you have to go for the alternative from step 1 in the advanced configuration (although I prefer not to change the overall size but use Ctrl+ and Ctrl- instead, to adjust the size of the email window)

  • 4
    This is quite a pain when you switch back and forth between docking station (with 1920x1200) and the laptop screen (3000x1800). Would be nice is this was automatic. – Wyrmwood Nov 21 '14 at 16:01
  • I added a link to the now working Firefox-Addon that sets the zoom for all elements to Factor 2 – rubo77 Nov 22 '14 at 22:36
  • the layout.css.devPixelsPerPx is a great suggestion, thanx! – eldad-a Aug 17 '16 at 22:08
4

I looks like Firefox 36.1 atleast, now picks up the scaling setting form Ubuntu. Its not dynamic - that is it reads the value when FF starts and its set at that until you restart FF. :)enter image description here

  • This should be the correct answer now. I also suspected I needed to restart the browser but thanks for confirming this with your answer. I restarted it immediately and it worked. – xji Jan 25 '18 at 17:56
  • Though sometimes there are still problems with how Firefox interprets the system value (it rounds it to the nearest integer), for some reason, so one might still want to specify layout.css.devPixelsPerPx manually. See the bug bugzilla.mozilla.org/show_bug.cgi?id=1214470 – xji Jan 25 '18 at 18:12
3

AutoHiDPI is another good solution.

  • 2019 09: Not available anymore. – Filbuntu Sep 3 at 0:01
  • I edited the link.The add-on is old, but probably works well on Waterfox – rubo77 Sep 3 at 5:36
-5

Use chromium-browser instead

Firefox supports minimal touch-screen usage for some time now, and can be adapted via some add-ons, but Chrome supports:

  • Pinch-to-zoom
  • scrolling with one finger

out of the box.

To adapt the resolution, You only need the system wide scaling

  • Is there a reason not to delete this question? – Filbuntu Sep 3 at 0:56
  • I think this is a valuable info for users, who wouldn't care to change the browser – rubo77 Sep 3 at 5:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.