1

I've got a bit of a conundrum that I can't find anything for, so I'm asking for help.

I recently got an AR2Drone from Parrot. I'd like to get some cool software on it, explore its file architecture, etc.

I don't have a laptop, just a PC. It's got an ethernet cable running to my router, and a usb wifi dongle that is connected to the drone's network. The drone acts as its own wifi router, allowing connections to it.

So far, I've been trying to use telnet to connect to the drone. If I turn my wired connection off, I lose internet connection, but I'm able to telnet into the drone and issue flight commands to it with some software I have. But the moment I turn the wired back on, all of that stops working.

Ideally, I'd like to be able to have my wired connection up along with the wireless connection, so that I don't have to lose my main internet connection while working on the drone. I'm baffled as to how to get this working though.

So I'm wondering if there is a way to force wlan0 to be my default connection, or set a specific terminal window to only use wlan0.

ifconfig output below:

eth0      Link encap:Ethernet  HWaddr 50:46:5d:6a:7e:2e  
          inet addr:192.168.1.4  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::5246:5dff:fe6a:7e2e/64 Scope:Link
          inet6 addr: 2002:188f:63a2:e472::1000/128 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1254101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:649052 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1708326009 (1.7 GB)  TX bytes:52385599 (52.3 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:13050 errors:0 dropped:0 overruns:0 frame:0
          TX packets:13050 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1823178 (1.8 MB)  TX bytes:1823178 (1.8 MB)

wlan0     Link encap:Ethernet  HWaddr c4:04:15:43:ed:6b  
          inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::c604:15ff:fe43:ed6b/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22263 errors:0 dropped:0 overruns:0 frame:0
          TX packets:806 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1142847 (1.1 MB)  TX bytes:101121 (101.1 KB)
2

You cannot have the same subnet on both interfaces! Essentially you're telling your PC that all 192.168.1.X computers are located off your eth0 interface and then again all 192.168.1.X are located off of wlan0. Change either of your subnets to 192.168.X.0 where X is not 1

  • Ok! Can I do this in the network manager from ubuntu, or do I need to use terminal commands? – user296986 Jun 23 '14 at 2:15
  • You need to do it on the router. Assuming you get you IP automatically via DHCP, most home routers have a web interface. So UNplug the connection that you want to keep at 192.168.1.X, then browse to most likely 192.168.1.1 and look at LAN subnet on the router settings and change it. – meccooll Jun 23 '14 at 3:28
  • Just what I needed. Than kyou – mk.. Jul 5 '16 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.