2

I recently installed a 14.04 over an old 13.04 install. Everything is running smoothly, but for some odd reason, whenever I tell it to reboot (graphically, reboot or otherwise), it just shuts down without actually rebooting. I find this behavior rather annoying.

Does anyone know how to fix this?

  • Very late comment, but restart is broken for me as well on 14.04, used to work on some older version. Also my laptop is a Latitude E5420, so this might be some bug very specific to Dell. Did you get it working in the mean time? – Bas Swinckels Aug 1 '15 at 12:44
  • I did not get it working. I will say, though, that this is occurring on a Latitude E5420m (and not my new Latitude E6540), so it could even be related to the model. – hal7df Aug 1 '15 at 13:25
0

You can try to black list the MEI driver. In here

/etc/modprobe.d/blacklist.conf

put this

# Make system reboot
blacklist mei

EDIT: Also try

sudo init 6

or

in /etc/default/grub

set

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

then

sudo update-grub

UPDATE:

reboot -f

OPTIONS -f, --force Does not invoke shutdown(8) and instead performs the actual action you would expect from the name.

or

sudo shutdown -r now

| improve this answer | |
  • Didn't work. Other suggestions? – hal7df Jun 22 '14 at 22:36
  • in /etc/default/grub set GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash" then sudo update-grub – Ruslan Gerasimov Jun 23 '14 at 0:45
  • Separately check this command, sudo init 6 – Ruslan Gerasimov Jun 23 '14 at 0:46
  • None of those worked either... – hal7df Jun 23 '14 at 2:19
  • reboot -f OPTIONS -f, --force Does not invoke shutdown(8) and instead performs the actual action you would expect from the name. – Ruslan Gerasimov Jun 23 '14 at 2:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.