Yesterday I've tried to watch a 3D movie in 2D mode with XBMC when I've noticed this would not work for me. I've looked at some errors I got while running XBMC from command line:

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: va_openDriver() returns -1
Failed to open VDPAU backend libvdpau_nouveau.so: cannot open shared object file: No such file or directory

I have to point out that the first time I had this error, it was "...nvidia.so" not nouveau - I think that changed because I've tried to switch to nouveau and then back to Nvidia. Now I'm actually unable to go back to Nvidia drivers (which sucks because up to this point I just used the "additional drivers" settings to switch back and forth).

After trying that I purged the Nvidia drivers because I noticed that the Nvidia X Server settings were installed but do not contain any settings, just the two pages Application Profiles and nvidia-settings Configuration. I've tried to install Nvidia drivers 331.38 via the "additional drivers" tool, no success. Additional drivers displays Nvidia 331.38 as active but my xorg log clearly states that:

[   352.415] (==) Matched nvidia as autoconfigured driver 0
[   352.415] (==) Matched nouveau as autoconfigured driver 1
[   352.415] (==) Matched nvidia as autoconfigured driver 2
[   352.415] (==) Matched nouveau as autoconfigured driver 3
[   352.415] (==) Matched modesetting as autoconfigured driver 4
[   352.415] (==) Matched fbdev as autoconfigured driver 5
[   352.415] (==) Matched vesa as autoconfigured driver 6
[   352.415] (==) Assigned the driver to the xf86ConfigLayout
[   352.415] (II) LoadModule: "nvidia"
[   352.495] (WW) Warning, couldn't open module nvidia
[   352.495] (II) UnloadModule: "nvidia"
[   352.495] (II) Unloading nvidia
[   352.495] (EE) Failed to load module "nvidia" (module does not exist, 0)

I've tried to install Nvidia drivers one more time but still the same errors from libva. It looks like my system uses nouveau now but nouveau is actually blacklisted inside "/etc/modprobe.d/nvidia-331_hybrid.conf"(Note that I have a geforce 660 TI installed - not a hybrid card)

I looked around for solutions but so far nothing seems to work. Did I do something wrong somewhere? I'd really like to get the Nvidia drivers working again and maybe even find out why my libva throws those errors.

On top of this I've just found this in my syslog (must be from before my last Nvidia reinstall because I'm not getting these messages anymore):

kernel: [   50.126660] nvidia: module license 'NVIDIA' taints kernel.
kernel: [   50.126665] Disabling lock debugging due to kernel taint
kernel: [   50.130161] nvidia: module verification failed: signature and/or  required key missing - tainting kernel
kernel: [   50.134126] NVRM: The NVIDIA probe routine was not called for 1 device(s).
kernel: [   50.134130] NVRM: This can occur when a driver such as: 
kernel: [   50.134130] NVRM: nouveau, rivafb, nvidiafb or rivatv 
kernel: [   50.134130] NVRM: was loaded and obtained ownership of the NVIDIA device(s).
kernel: [   50.134133] NVRM: Try unloading the conflicting kernel module (and/or
kernel: [   50.134133] NVRM: reconfigure your kernel without the conflicting
kernel: [   50.134133] NVRM: driver(s)), then try loading the NVIDIA kernel module
kernel: [   50.134133] NVRM: again.
kernel: [   50.134136] NVRM: No NVIDIA graphics adapter probed!
kernel: [   50.134137] [drm] Module unloaded
kernel: [   50.134203] NVRM: NVIDIA init module failed!

Thanks for reading, if you think important information is missing please let me know.

All Links and further information about this are welcome (because this is driving me nuts!) :)

  • Try with sudo apt-get install linux-headers-generic xserver-xorg-video-all libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core – user308564 Jun 23 '14 at 6:46

I have found a solution to my problems.

Blacklist nouveau:

sudo nano /etc/modprobe.d/blacklist-nouveau.conf


blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off

Ctrl+O and Ctrl+X to exit.

After that I just stopped the x server and rebuilt initramfs.

Ctrl+Alt+F1 to go to TTY1. Log in.

sudo service lightdm stop
sudo update-initramfs -u

Restart with shutdown -r 0. vainfo still returns errors but it also shows information about profiles and entrypoints. Like this:

libva info: VA-API version 0.35.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva info: Found init function __vaDriverInit_0_32
libva info: va_openDriver() returns 0
vainfo: VA-API version: 0.35 (libva 1.3.0)
vainfo: Driver version: Splitted-Desktop Systems VDPAU backend for VA-API - 0.7.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileMPEG4Simple            : VAEntrypointVLD
      VAProfileMPEG4AdvancedSimple    : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD

Only sad thing now is the fact that I have no clue what caused all this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.