0

I'm trying to install Lilypond on a 32-bit system, and for some reason the sh file simply does not want to execute itself.
I'm completely new to Ubuntu, so I have next to no knowledge of how anything works. But I've looked around and tried a few things. I've checked "allow executing file as program" in Properties, but I don't see any option of executing the file, only opening it with gedit or Libreoffice writer.

I've tried,

chmod u+x lilypond

and

chmod u+x lilypond-2.18.2-1.linux-x86.sh 

but both times it said

chmod: cannot access [filename I entered]. No such file or directory

I've seen a suggestion for something like:

cd /path/to/file  
chmod +x filename.sh  
./filename.sh  

but I don't even know how to make a command line with more than one line. Does anyone know what I can do?.

  • Run the above commands separately(ie, one by one) – Avinash Raj Jun 22 '14 at 16:12
1

If you don't need a specific version of lilypond, just execute the following to install a stable version of lilypond:

sudo apt-get install lilypond

Alternatively, use the software center or synapticto install lilypond.

The Ubuntu 14.04 package repository contains lilypond 2.16. The upcoming 14.10 will likely have lilypond 2.18.

In general, installing software "manually" (as you've tried) is only required in certain cases: for example, if you require a specific version that isn't available in the ubuntu software repositories, or if you want to install anything that's missing completely in the repos. So, it's usually the easiest way to check the software repositories (via Software center or synaptic) first.

  • I'm trying this and it seems to be working. Do you know whether this'll get me the stable or the unstable version? I'd prefer stable. – user294509 Jun 22 '14 at 21:51
  • I'm almost sure it's a stable version, if you didn't change anything regarding package sources. – tohuwawohu Jun 23 '14 at 5:36
0

Succinctly, you will need to

  1. Open the terminal program (CTRL+ALT+T in Ubuntu).
  2. Change to the directory that contains the file that you downloaded. That is a done with a command with the following form:

    cd /home/username/Downloads

    (Naturally, you should substitute the file’s actual path for /home/username/Downloads.)

  3. The file you download (assuming it is the latest stable version of LilyPond) should be called lilypond-2.18.2-1.linux-x86.sh. You will need to ensure that is executable (able to be run as a command). To do this, type

    chmod +x lilypond-2.18.2-1.linux-x86.sh
  4. Now, run the installation script, using the following command:

    ./lilypond-2.18.2-1.linux-x86.sh
  5. If for some reason the installation script fails (it tends to do so when the 32-bit LilyPond is being installed on a 64-bit version of Linux), try using the following command instead:

    bash lilypond-2.18.2-1.linux-x86.sh
  6. If you accept all of the default options, the script will install LilyPond in a directory called /home/username/lilypond (where username represents your own user name). You will need to add this directory to your execution path, which is done by issuing the following command:

    export PATH=$PATH:$HOME/lilypond/usr/bin
  7. You will either need to issue this commend every time you want to use LilyPond after opening a new terminal window, or else add it to one of your startup scripts (e.g., .bashrc). To do this last step, type the following in your terminal window:

    echo 'export PATH=$PATH:$HOME/lilypond/usr/bin' >> ~/.bashrc
    (You can copy and paste this last command as-is.)

You should be good to go. To compile a file named, say, music.ly, type lilypond music.ly in a terminal window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.