I'm using brscan4 and can ping it using brsaneconfig4 and it finds it but i cannot scan from the computer using either simple scan or xsane image scanning. Both programs don't show the scanner as being present. Brother drivers downloaded and installed

dpkg -l | grep Brother

ii  brscan-skey                                                 0.2.4-1                                             amd64        Brother Linux scanner S-KEY tool
ii  brscan4                                                     0.4.2-1                                             amd64        Brother Scanner Driver
ii  cupswrapperdcp7065dn                                        2.0.4-2                                             i386         Brother DCP7065DN CUPS wrapper driver
ii  dcp7065dnlpr                                                2.1.0-1                                             i386         Brother DCP-7065DN LPR driver
ii  printer-driver-ptouch                                       1.3-8                                               amd64        printer driver Brother P-touch label printers

If i press the scan button on the machine it tells me to "Check Connection" I've tried everything i can on the forums to no avail. Any ideas?

SOLVED the only thing that i can think of that I hadn't done was, in terminal created a scanner using brsaneconfig4:

brsaneconfig4 -a name=DCP-7065DN model=DCP7065DN ip= Get the IP Address by using the Menu button on the printer/scanner, select network, then TCP / IP, then IP Address.

I spent hours trawling the forums but the scanner started working when I RESTARTED THE COMPUTER and all was well. xsane picked it up and simple scan.

Still can't use the scan button on the machine but not worried about it.


Download and install drivers from the Brother website.

Select 'Driver Install Tool' download and install. This will install the lpr, CUPSwrapper and scanner drivers. Make sure you get the right ones for your operating system (i.e. 64-bit or 32-bit). I did this step over and over again and so I can't remember whether the package installed the right ones first time or not. The brother website has instructions for installing the drivers, make sure you follow them.

Open terminal and enter


This should come up with something like this

    USAGE: brsaneconfig4 [-OPTION]   OPTION:
   -a name=FRIENDLY-NAME model=MODEL-NAME ip=xx.xx.xx.xx    
   -a name=FRIENDLY-NAME model=MODEL-NAME nodename=BRN_xxxxx 
               : Add network scanner
               : Remove network scanner
   -q          : Query supported models and available network scanners
   -d          : Diagnosis
   -p          : Ping (for network scanners)  
   -s:[LABEL]  : Save current configuration
   -l:[LABEL]  : Load saved configuration

Find the IP address by plugging in and turning on the printer and then hitting the menu button until you get 'Network' press the down arrow button to select 'TCP/IP' then 'IP Address'. Alternatively you can do this by using brsaneconfig4

    brsaneconfig4 -p

Then you'll have to create your scanner for the scanner programs to see by entering this in terminal

    brsaneconfig4 name=put the name you want to call your printer here model=DCP7065DN ip=xxx.xxx.xxx.xxx

where x's are the numbers from the IP address you've just discovered. Then RESTART YOUR COMPUTER!!

    sudo reboot

To get the scan button to work you need to run the scan key (this bit is apparently 64bit or 32bit specific) so there may be some issues here if you don't have the right one.


then test if it sees your scanner

    brscan-skey -l

this should show you the name you just entered for the scanner.

Edit Apparently you need to run brscan-skey command once every session that you want to use the scan key. Open Startup Applications and enter


as a command to get it to run automatically.

Apparently you need to have gimp installed to use the printer/scanner scan button. It is certainly the program that opens the scans on my computer.

You need to have installed sane-utils, but brother mention this in their instructions.

All done! Good luck!

p.s The printer stopped working over the network for only my ubuntu computers after an update. I found that it was not accepting full length ip addresses (that is 3digits.3digits.3digits.3digits). It started working again after I took out any zeroes at the start of any 3digit sequence, so .066 became .66 in the device url section of the printer properties under printers in the general settings e.g



  • Interesting, I've never even considered using leading zeros in an ip address... It seems superfluous to me, but that's just my humble opinion. – Elder Geek Aug 23 '15 at 14:33
  • 1
    Superfluous yes, what is on the IP screen on the printer yes. So that is probably what most people would put in the IP address textbox when prompted to, unless they work with IP addresses and understand them better than me. – The Tick Sep 1 '15 at 4:10
  • What do I put for the ip if my printer is connected by usb? – Marcel Sep 25 '15 at 17:05
  • 1
    I would guess you don't need an IP address unless you are running the printer over the network, which you probably aren't if it is connected via USB. – The Tick Jan 20 '16 at 0:45
  • > It started working again after I took out any zeroes at the start of any 3digit sequence This is an often-made error. The leading 0 at the start of the address byte makes the parser software interpret this number as an OCTAL number, not as a decimal. So 066 (octal) = 54 (decimal), quite possibly not what you intended. – Arjen Jan 28 at 14:47

In my case, the upgrade modified the sane dll config file.

I discovered this:


... that contained the line


while /etc/sane.d/dll.conf just said


After updating dll.conf scanning worked immediately.

I am on Ubuntu 14.04, using a Brother MFC-7440N network-attached (which uses a brscan3 driver).


Thank You! I had to tweak your solution a little but for others who may be having this problem here is what I did... (And I apologize, I don't know how highlight the commands).

In terminal:

brsaneconfig4 -a name=BrotherMFC-J470DW model=MFC-J470DW ip=xxx.xxx.x.xx

(Note : I removed the leading zeros in the IP)


brscan-skey -l

I also added the brscan-skey to the Application Startup as suggested. Everything works like a charm!

Thanks again! Jodie

  • Welcome to Ask Ubuntu! ;-) Please edit the original answer instead of posting a new one: that way it's easier for the next user to have all data in one spot. Then delete this one. Also, please review the editing help to improve the readability of your answers in the future... ;-) – Fabby Feb 23 '16 at 23:16
  • Alas, in my case brscan-skey -l did not find the scanner, which works correctly in every aspect other than the scan button. – Paul A. Dec 10 '17 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.