3

I'm trying compare images as described on this Website but therefor I need to have JAI installed. I have downloaded the file jai-1_1_3-lib-linux-amd64.tar.gz from here.

I've also looked into the installationguide but I feel kind of lost and don't know how to go on from here.

My specs:

OS: Ubuntu 14.04 Trusty Tahr - 64bit

Java: java version "1.6.0_41" Java(TM) SE Runtime Environment (build 1.6.0_41-b02) Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01, mixed mode)

If any other information is needed, I'll be happy to provide it.

Thanks in advance!

4

You should use the version in the official repositories if you can. Just run this to install:

sudo apt-get install libjai-core-java

If you still want to go your way, just download a binary version, add executable permissions and run it:

wget http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-linux-amd64-jre.bin
chmod +x jai-1_1_3-lib-linux-amd64-jre.bin
sudo ./jai-1_1_3-lib-linux-amd64-jre.bin

# finally, you can delete the installer if you want
rm jai-1_1_3-lib-linux-amd64-jre.bin
  • I installed it from the official repo but for some reason eclipse still says The import javax.media cannot be resolved – Jamie-505 Jun 23 '14 at 6:52
  • I now this turn out to be a problem that might better be asked on stackoverflow, but since I started this question here, I might as well continue here, so: I've now downloaded the JMF as described here and added it in eclipse as described here Now eclipse says: The import javax.media.jai. cannot be resolved – Jamie-505 Jun 23 '14 at 7:14
  • I finally solved my problem. I just extracted the file jai-1_1_3-lib-linux-amd64.tar.gz into /opt/JAI and added it to my project via ***right click on the project -> Build Path -> Configure Build Path... -> Libraries -> Add External JARs -> select /opt/JAI/jai-1_1_3/lib/jai_codec.jar and /opt/JAI/jai-1_1_3/lib/jai_core.jar – Jamie-505 Jun 23 '14 at 7:27
  • @Jamie-505 did the libjai-core-java package out of apt not work for you? I've tried using it for my application but even if I copy their jars on top of the pure-java jai jars my application shipped with, it doesn't run. :\ – James T Snell Jun 15 '16 at 0:34
  • E: Unable to locate package libjai-core-java under 16.04. Any hint for that? – ar2015 Sep 20 '18 at 4:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.