1

On my y510p, I set Lenovos battery software to "Optimize battery health" while I was in Windows 8.1. I forgot to change it before overwriting that partition with Ubuntu, and now my battery in Ubuntu never charges past 59~60%. I think this is due to something in the BIOS because it persists despite my Windows partition being gone.

I've searched the BIOS but there's no mention of battery anywhere!

I'm using Ubuntu 14.04 LTS.

4
  • 1
    Guess you might need to install Windows again for the time being
    – Raphael
    Jun 22, 2014 at 5:58
  • Same issue, same laptop model, same OS here. The battery charged fine until a few days ago; I bought the computer without an OS, so I never had Windows on it (and thus never made any changes in Windows' power management application). It simply stopped charging all of a sudden. All solutions online mention changing some settings in a Windows app :(
    – mingos
    Jul 9, 2014 at 6:32
  • Did you try checking for an EFI partition? When I check the partitions on my hard drive, there was still a 3GB partition, which I believe was the EFI partition on the original Windows install. I have a feeling that partition may contain battery charging data - otherwise, how else would a completely different OS know? I'm going to try deleting that and seeing if it works
    – Jin
    Jul 9, 2014 at 17:21
  • @jim it knows because the hardware is doing it, not the OS. Aug 29, 2015 at 12:51

2 Answers 2

1

Since the answer Intruder is a little bit dated and doesn't contain an answer, only the link, the solution he provides is as follows (originally provided by yigit from the lenovo forum):

  1. Shutdown your Laptop.
  2. Remove the battery and the AC.
  3. Press the Power-Button for 30-40 seconds.
  4. Put everything back together and start reboot your laptop.

Also: According to some more sources it doesn't seem to be OS related but more hardware related. As far as I could understand, you are resetting your CMOS with the steps above. It worked for me and my Lenovo E530.

1
  • I agree that it probably is a hardware related issue. For the record, I solved my issue by reinstalling Windows 8.1, installing the Lenovo battery software, and turning the "Optimize battery health" setting off.
    – Jin
    Feb 4, 2016 at 8:14
0

For the Lenovo G70-70 the answer is: reinstall Windows and the Lenovo Power Manager. I tried installing Linux programs that could in principle regulate the charge, but Synaptics returned strange warnings and would not let me install those scripts. After switching off the offensive setting I installed Linux again (besides Windows this time) and everything is fine.
The suggestion by mspl that you could empty the cmos by holding down the power button did not work, either. Strange: for a short time, the charge did rise to 71%. After that it was 60% again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.