0

I've run boot repair, uncommented the GRUB_GFX line, and set the resolution to 1366x768x60 (the 60 part is the refresh rate, right?) with Grub Customizer. I still got the error, so I reinstalled/updated Grub.

Then, I saw that all the guides I read had the resolution on the GRUB_GFX line without quotes, so at a last-ditch attempt to fix it, I typed "gksudo gedit /etc/default/grub", removed the quotes, updated, and restarted. I still get the error "Input out of range, change to 1366x768 - Refresh rate 60" when grub loads. Now, grub still works of course, If I hit enter Ubuntu loads, if I arrow down 5 lines and hit enter Windows 7 loads.

I only get this error in grub, all the OS GUIs load fine, even the Ubuntu recovery mode terminal. All I can say is good god, I think I'm about to give up and just go into grub customizer, write down the boot order and number of key presses needed to get to each option, and forgo the grub GUI completely since I know where everything is. Trouble is, this is my mom's computer and while I could tell her where everything is and what buttons to press, she would forget.

I really don't want to give up, is there ANYTHING else I can do? Is there something I might be doing wrong? The PC Is a Compaq Presario CQ5210F Desktop with the stock monitor if that helps (Though I don see how it would).

Here's my grub.cfg:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE="1366x768x60"

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux


Note that it seems to have automatically added back the quote marks

Here's my boot-repair log: http://paste.ubuntu.com/7683018/

  • Ok, I know it might be too early too tell and I'm probably just being impatient, but I've noticed that none of my questioned get answered or even viewed by anyone but me on any stack exchange site. Have I been blacklisted or something? – user281058 Jun 22 '14 at 4:03
  • Nah, you're post is visible just fine for me. I tried with 1366x768x60 on my laptop and it worked fine. Do your graphics card and your monitor support that resolution and frame rate? Can you try the accepted answer here: askubuntu.com/questions/103516/…? – muru Jun 22 '14 at 5:01
0

Run this command:

gksudo gedit  etc/default/grub

A proper grub file should look like this:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

The only differences I see in your file is that there are "" at places not needed at all.

Just edit those lines and save. Then reboot.

Hope it works for you this time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.