3

SOLVED: See OP's Answer below

I am trying to install Ubuntu alongside Windows 8.

I have a laptop that has been through various dual-boot configs. At one point, I was only running Linux Mint. Eventually, I wanted Windows 8 back to run Visual Studio. I decided to complete remove everything, and reinstall Win8. Now, I am wanting to install Ubuntu alongside Windows to learn a thing or two about Hadoop.

I have disabled Secure and Fast boot. Actually, Secure boot isn't even an option - I happened to install Windows 8 from a USB created by Windows 7 Live USB Creator Tool. Silly mistake on my part, it doesn't create USBs that are UEFI capable. Legacy/CSM works just fine though. Do note, however, that if you are doing the same - you must delete the EFI directory from the LiveUSB you are installing Ubuntu from. Otherwise, you will end up with Windows for CSM boot mode and Ubuntu for UEFI boot mode.

Either way, upon install - No other OS is found. Not to worry, I've been here before and created partitions. However, my next screen disturbing: enter image description here

Basically, the partition that I set aside for Ubuntu isn't found and all it recognizes is that there's a single hard drive waiting to run amok on. Help?

Output of sudo parted -l:

Warning: /dev/sda contains GPT signatures, indicating that it has a GPT table.
However, it does not have a valid fake msdos partition table, as it should.
Perhaps it was corrupted -- possibly by a program that doesn't understand GPT
partition tables.  Or perhaps you deleted the GPT table, and are now using an
msdos partition table.  Is this a GPT partition table?

Model: Generic Flash Disk (scsi)
Disk /dev/sdb: 4299MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  |  Start  |  End   |  Size  |   Type   | File system | Flags

 1      | 1049kB  | 4299MB | 4298MB |  primary |   fat32     | boot, lba

Output is the same for both Yes and No.

Note There was 300GB/750GB partitioned, using Windows Disk Management, which I plan to put Ubuntu on. The command sudo parted -l is displaying info on the Windows partition.

  • Did you try a live dvd and checking with gparted to see what partitions are there? – mixso Jun 22 '14 at 3:21
  • 1
    Yep, it doesn't recognize anything. There is just 750gb of unallocated space. – Joe Jun 22 '14 at 3:22
  • 1
    Add the output of sudo parted -l to your question. – psusi Jun 22 '14 at 3:23
  • 1
    In regards to your Windows usb-stick not booting in UEFI, it's likely the tool you used to create it only supports BIOS. For example the official Microsoft Windows 7 USB Creator Tool only supports BIOS. If you burn your iso to a dvd it should boot in UEFI mode successfully. – please delete me Jun 22 '14 at 4:45
  • 1
    Correct, I used Windows 7 USB Creator Tool because I didn't have any blank DVDs lying around... Sharp catch – Joe Jun 22 '14 at 6:58
6

The solution is here

And the exact steps it took to get my partitions to be recognized again are as follows...

  1. Open a Terminal and run sudo gdisk /dev/sda
  2. It is likely that both MBR and GPT will be found and asks you which one to use - the choice is irrelavant.
  3. Type x for the next command because well, you're doing expert stuff
  4. Type z to zap the GPT data
  5. Type y to proceed destroying GPT data
  6. Type n in order to not lose MBR data

Opened GParted, no Warning message about GPT signatures and my partitions are recognized :)

Thanks all for your time and advice

|improve this answer|||||
  • After doing this have you fully gotten back the "original-harddisk-with-Windows" when you bought the Windows? Or are there still differences? – Pacerier Nov 9 '15 at 19:26
1

Did you try using TestDisk to check for partitions?

Another option would be to use the whole disk and then install Windows 8 in virtual box.

|improve this answer|||||
  • 1
    I just tried TestDisk (on the LiveUSB of Ubuntu). I tried the fidenity_static and the log file it outputs doesn't contain anything. photorec_static created a .ses extension file that I can't read. And the testdisk_static doesn't do anything as far as I can tell. Also, I need all of my limited resources for Windows 8.. VirtualBox is out of the question – Joe Jun 22 '14 at 3:56
  • TestDisk has always taken me some time to complete using the Check for lost partitions and then Deeper Search. How did you manage to get the Partitions Search done so quick? – mixso Jun 22 '14 at 4:19
  • 1
    Solution has been found, just posted the answer. – Joe Jun 22 '14 at 4:20
  • It would be a good idea to include instructions on how to use/install TestDisk. Alternatively the question as it is would be fine as a comment on the original posting. – please delete me Jun 22 '14 at 5:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.