My Dell XPS 13 have a terrible connection and I have a limited range of where it will connect to my router(15-20ft). I have tried to turn off the power manager but it doesn't seem to make too much of a difference.

sudo modprobe iwlwifi 11n_disable=1

I also tried to disable hardware. I didn't notice too much of a difference. But I could have also done it incorrectly. (how do I know if I did this right/wrong?)

lshw -C network


description: Wireless interface

       product: Centrino Advanced-N 6235
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 24
       serial: c8:f7:33:ca:53:2d
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-29-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
       resources: irq:45 memory:d0400000-d0401fff

sudo iwconfig

lo        no wireless extensions.
wlan0     IEEE 802.11abgn  ESSID:"HOME-32E2"
Mode:Managed  Frequency:2.462 GHz  Access Point: 0C:F8:93:A9:32:E0
Bit Rate=27 Mb/s   Tx-Power=15 dBm
Retry  long limit:7   RTS thr:off   Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=47/70  Signal level=-63 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:244  Invalid misc:143699   Missed beacon:0

Reboot your computer then try the parameter this way:

echo "options iwlwifi 11n_disable=1" | sudo tee -a /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi
  • I think it is sudo tee -a Otherwise, it wipes the preceding file contents. – chili555 Jun 21 '14 at 21:16
  • @chili555 thank you, I added the -a. – Wild Man Jun 21 '14 at 21:25

This is a known problem with the device itself, it also happens on Windows. In the following monster thread with more than 70 pages, you can see that over a period of two years Intel is continuously failing to fix this device. And it looks like they will never be able to get it working.

The only solution is to toss this piece of crap card out of the window and buy another model.

  • Somewhat ironically, that vendor forum is currently down for maintenance. In the mean time, an archived copy of the "monster thread" referred to in this post may be accessed here. – Eliah Kagan Aug 14 '14 at 15:28

Same wifi interface on a Samsung Ultra series 7. I had unstable connection: connection lost every minute. In my case the solution was to change encription protocol of my AP from WPA2/TKIP to WPA2/AES.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.