1

Running Ubuntu 14.04 on a custom desktop. I have Encore wireless N300 PCI-E Adapter ( seen here ) The driver is available for download at this link as well. I've read that a possible fix for connection issues is to uninstall/reinstall the wireless driver. It seems like there should be some other options to try first.

It only drops connection for a second, and then re connects. I can see the WiFi icon constantly fluctuating weak to strong.

Note: I also have this posted for a few days in Ubuntuforums and Unix Linux, but I've gotten no response yet. I'm just looking for a push in the right direction.

lspci

Network controller: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter (rev 01

lsmod | grep rtl

rtl8192ce              53550  0
rtl_pci                26690  1 rtl8192ce
rtlwifi                63475  2 rtl_pci,rtl8192ce
rtl8192c_common        53172  1 rtl8192ce
mac80211              626557  3 rtl_pci,rtlwifi,rtl8192ce
cfg80211              484040  2 mac80211,rtlwifi

iwconfig | grep Power
eth0      no wireless extensions.

lo        no wireless extensions.

          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm  
          Power Management:off

WIRELESS Script*

########## wireless info START ##########

##### release #####

Distributor ID:    Ubuntu
Description:    Ubuntu 14.04 LTS
Release:    14.04
Codename:    trusty

##### kernel #####

Linux mike-System-Product-Name 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:00:20 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

##### lspci #####

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 09)
    Subsystem: ASUSTeK Computer Inc. P8H77-I Motherboard [1043:8505]
    Kernel driver in use: r8169

06:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178] (rev 01)
    Subsystem: Realtek Semiconductor Co., Ltd. RTL8192CE PCIe Wireless Network Adapter [10ec:8178]
    Kernel driver in use: rtl8192ce
07:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller [1b21:1042]

##### lsusb #####

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 04d9:a06b Holtek Semiconductor, Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 002: ID 03f0:8904 Hewlett-Packard DeskJet 6940 series
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA Card Info #####

##### rfkill #####

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

##### iw reg get #####

country 00:
    (2402 - 2472 @ 40), (3, 20)
    (2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
    (5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
    (5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

##### interfaces #####

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

##### iwconfig #####

wlan0     IEEE 802.11bgn  ESSID:"HighMoon"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: <MAC address removed>  
          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=20 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:88   Missed beacon:0

##### route #####

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     9      0        0 wlan0

##### resolv.conf #####

nameserver 127.0.1.1
search hsd1.pa.comcast.net

##### nm-tool #####

NetworkManager Tool

State: connected (global)

- Device: wlan0  [HighMoon] ----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192ce
  State:             connected
  Default:           yes
  HW Address:        <MAC address removed>

  Capabilities:
    Speed:           144 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    HighMoon-guest:  Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 97
    *HighMoon:       Infra, <MAC address removed>, Freq 2437 MHz, Rate 54 Mb/s, Strength 100 WPA2

  IPv4 Settings:
    Address:         192.168.1.146
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             75.75.76.76
    DNS:             75.75.75.75
    DNS:             192.168.1.1

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            r8169
  State:             unavailable
  Default:           no
  HW Address:        <MAC address removed>

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

##### NetworkManager.state #####

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf #####

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### iwlist #####

wlan0     Scan completed :
          Cell 01 - Address: <MAC address removed>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=26 dBm  
                    Encryption key:on
                    ESSID:"HighMoon"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 0ms ago
                    IE: Unknown: 0008486967684D6F6F6E
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606081500000000000000000000000000000000000000
                    IE: Unknown: DD810050F204104A00011010440001021041000100103B0001031047001002519461683B1AF5B2843176671BB6DB102100074C696E6B7379731023000D4C696E6B7379732045343230301024000776312E302E30321042000234321054000800060050F20400011011000D4C696E6B737973204534323030100800020084103C000103
                    IE: Unknown: DD090010180203F02C0000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
          Cell 02 - Address: <MAC address removed>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=26 dBm  
                    Encryption key:off
                    ESSID:"HighMoon-guest"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 0ms ago
                    IE: Unknown: 000E486967684D6F6F6E2D6775657374
                    IE: Unknown: 010882848B962430486C
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 2F0100
                    IE: Unknown: 32040C121860
                    IE: Unknown: 2D1AFC181BFFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1606081100000000000000000000000000000000000000
                    IE: Unknown: DD090010180200F02C0000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00

##### iwlist channel #####

wlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Current Frequency:2.437 GHz (Channel 6)

##### lsmod #####

rtl8192ce              53550  0
rtl_pci                26690  1 rtl8192ce
rtlwifi                63475  2 rtl_pci,rtl8192ce
rtl8192c_common        53172  1 rtl8192ce
mac80211              626557  3 rtl_pci,rtlwifi,rtl8192ce
cfg80211              484040  2 mac80211,rtlwifi

##### modinfo #####

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192ce/rtl8192ce.ko
firmware:       rtlwifi/rtl8192cfwU_B.bin
firmware:       rtlwifi/rtl8192cfwU.bin
firmware:       rtlwifi/rtl8192cfw.bin
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     EF063698748457BBEDB4633
alias:          pci:v000010ECd00008176sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008177sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008178sv*sd*bc*sc*i*
alias:          pci:v000010ECd00008191sv*sd*bc*sc*i*
depends:        rtlwifi,rtl_pci,rtl8192c-common,mac80211
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512
parm:           swenc:Set to 1 for software crypto (default 0)
 (bool)
parm:           ips:Set to 0 to not use link power save (default 1)
 (bool)
parm:           swlps:Set to 1 to use SW control power save (default 0)
 (bool)
parm:           fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
parm:           debug:Set debug level (0-5) (default 0) (int)

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtl_pci.ko
description:    PCI basic driver for rtlwifi
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     9B7F19319428FF0EFE7E350
depends:        mac80211,rtlwifi
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtlwifi.ko
description:    Realtek 802.11n PCI wireless core
license:        GPL
author:         Larry Finger    <Larry.FInger@lwfinger.net>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     27E91755814596D634B7709
depends:        mac80211,cfg80211
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512

filename:       /lib/modules/3.13.0-29-generic/kernel/drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.ko
description:    Realtek 8192C/8188C 802.11n PCI wireless
license:        GPL
author:         Larry Finger    <Larry.Finger@lwfinger.net>
author:         Ziv Huang    <ziv_huang@realtek.com>
author:         Georgia        <georgia@realtek.com>
author:         Realtek WlanFAE    <wlanfae@realtek.com>
author:         lizhaoming    <chaoming_li@realsil.com.cn>
srcversion:     32F826C623BC49F764F7974
depends:        
intree:         Y
vermagic:       3.13.0-29-generic SMP mod_unload modversions
signer:         Magrathea: Glacier signing key
sig_key:        <MAC address removed>:3B:EA:01:C4:BD:A9:65:67:CF:A7:23:C9:70:D8
sig_hashalgo:   sha512

##### modules #####

lp
rtc

coretemp
nct6775

coretemp
nct6775

##### blacklist #####

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/fbdev-blacklist.conf]
blacklist arkfb
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist cirrusfb
blacklist cyber2000fb
blacklist gx1fb
blacklist gxfb
blacklist kyrofb
blacklist matroxfb_base
blacklist mb862xxfb
blacklist neofb
blacklist nvidiafb
blacklist pm2fb
blacklist pm3fb
blacklist s3fb
blacklist savagefb
blacklist sisfb
blacklist tdfxfb
blacklist tridentfb
blacklist viafb
blacklist vt8623fb

##### udev rules #####

# PCI device 0x10ec:0x8168 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

# PCI device 0x10ec:0x8178 (rtl8192ce)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC address removed>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #####

[    5.120047] rtl8192ce: Using firmware rtlwifi/rtl8192cfw.bin
[    5.194147] ieee80211 phy0: Selected rate control algorithm 'rtl_rc'
[    5.194286] rtlwifi: wireless switch is on
[    8.897871] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[    8.898113] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   11.059263] wlan0: authenticate with <MAC address removed>
[   11.079193] wlan0: send auth to <MAC address removed> (try 1/3)
[   11.080713] wlan0: authenticated
[   11.082910] wlan0: associate with <MAC address removed> (try 1/3)
[   11.085949] wlan0: RX AssocResp from <MAC address removed> (capab=0x411 status=0 aid=2)
[   11.086080] wlan0: associated
[   11.086087] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   11.130630] wlan0: deauthenticating from <MAC address removed> by local choice (reason=2)
[   11.161112] wlan0: authenticate with <MAC address removed>
[   11.507939] wlan0: send auth to <MAC address removed> (try 1/3)
[   11.509417] wlan0: authenticated
[   11.510494] wlan0: associate with <MAC address removed> (try 1/3)
[   11.517862] wlan0: RX AssocResp from <MAC address removed> (capab=0x411 status=0 aid=2)
[   11.517993] wlan0: associated
[   19.514761] wlan0: Connection to AP <MAC address removed> lost
[   20.825705] wlan0: authenticate with <MAC address removed>
[   20.845680] wlan0: send auth to <MAC address removed> (try 1/3)
[   20.849279] wlan0: authenticated
[   20.853472] wlan0: associate with <MAC address removed> (try 1/3)
[   20.856489] wlan0: RX AssocResp from <MAC address removed> (capab=0x411 status=0 aid=2)
[   20.856620] wlan0: associated

########## wireless info END ############

Also went into Network Manager and locked in BSSID number in previously blank field. Still, I see the WiFi icon fluctuating. BSSID found through running:

cat /var/log/syslog | grep -e etwork -e wlan | tail -n20

Which gave me a message:

WLAN:0 WPA: GROUP
Rekeying completed with ( BSSID NUMBER)
[GTK=CCMP]

EDIT/FOLLOW UP: Per @Wild Man'comment: I found the only thing I could or needed to change was "ignore" in ipv6. Following that I ran the commands provided in his answer on the linked thread. After doing so, I was not able to re-connect via wireless until I rebooted, and then it takes a long time to open up start page. I am now online, but my WiFi icon/network is still fluctuating. Here's an output of

grep -R [[:alnum:]] /sys/module/rtl8192ce/parameters


/sys/module/rtl8192ce/parameters/ips:N
/sys/module/rtl8192ce/parameters/debug:0
/sys/module/rtl8192ce/parameters/fwlps:Y
/sys/module/rtl8192ce/parameters/swenc:Y
/sys/module/rtl8192ce/parameters/swlps:N

EDIT 2 Tried removing parameters with :

sudo rm /etc/modprobe.d/rtl8192ce.conf

Afterwards My readout with: grep -R [[:alnum:]] /sys/module/rtl8192ce/parameters

/sys/module/rtl8192ce/parameters/ips:Y
/sys/module/rtl8192ce/parameters/debug:0
/sys/module/rtl8192ce/parameters/fwlps:Y
/sys/module/rtl8192ce/parameters/swenc:N
/sys/module/rtl8192ce/parameters/swlps:N

So I ran:

sudo modprobe -rv rtl8192ce
sudo modprobe -v rtl8192ce fwlps=0

Which did set fwlps to :N. However I was disconnected fully until reboot.

  • 1
    The answer at this link usually fixes the issue you are having if possible but some people still have to install a new driver. askubuntu.com/questions/482564/… – Wild Man Jun 21 '14 at 13:52
  • I don't think I have the option to change from "bgn". I am set to WPA2 personal. My channel is set to 11. I'm on e4200 cisco. Should I just run the commands,or are you seeing something that doesn't look right? – 5th Wheel Jun 21 '14 at 14:45
  • I should say that what I'm looking at could be different than what I "should" be looking at. Under Wireless>Wireless network>2.4ghz I have 'Channel 11' and Mode is Mixed. – 5th Wheel Jun 21 '14 at 15:20
  • The commands often help this driver that has been problematic for at least the last two years. If everything that I suggested has been done and it does not help then you will need to compile a new driver. Is mixed mode your encryption in your router or in network manager? Some routers their are settings that can not be changed but not many are that way. Most settings are in a drop down menu that you just click on to change them. – Wild Man Jun 21 '14 at 20:26
  • Mixed mode was listed in Router configuration page under STATUS>Wireless Network and listed as Mode:__. 2.4ghz is listed as channel 11. On network Manager, I have Security as WPA and WPA2 personal. I ran through the commands provided in your linked thread and edited at the bottom of my O.P. – 5th Wheel Jun 22 '14 at 16:06
1

Install the dependencies required to compile the driver:

sudo apt-get install --reinstall linux-headers-generic linux-headers-$(uname -r) build-essential dkms

Click here to download the newest driver to your computer then right click and extract here.

Then compile the driver using the directions below.

cd ~/Downloads/backports-3.16-rc1-1
make defconfig-rtlwifi
make
sudo make install

Reboot
When you have an upgrade to the kernel you will need to do:

cd ~/Downloads/backports-3.16-rc1-1
make clean
make defconfig-rtlwifi
make
sudo make install

Reboot

Thanks to chili555 for finding and testing this driver, the driver compiled on two different computers.

  • What, if any, tests should I run to see if it worked? Granted, I just installed 5 minutes ago, but after restart I am now still seeing Network icon fluctuate. I ran a speedtest, and that seems to be the same as before(which was good) but seeing the wifi bounce from 0 to 4 bars has me concerned. – 5th Wheel Jun 23 '14 at 18:48
  • I always see that to in ubuntu but it does not affect my connection. The parameters you set with the other driver do you still have them? I would just use the connection for a little while and see if it is better, keep in mind with this driver better may be the best you can hope for. Did you change to just b/g settings to see if it made the connection more stable? Unless you have a connection faster then 54 mbs it is not going to slow down the connection of other devices. – Wild Man Jun 23 '14 at 19:18
  • 1
    I didn't change to B/G, because I actually take advantage of average 100 mbps on isp, and 200mbps on closest server through vpn.The entire concern for all of this is that when I drop connection for a second, it knocks me off VPN and reconnects clean, leaving me exposed. VPN killswitch is a hassle, so I was hoping to get a stable connection. I fixed this exact problem with my last computer, same driver, but the same process didn't work here. – 5th Wheel Jun 23 '14 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.