I'm unable to use my print screen button in Ubuntu 14.04. No effect pressing print screen. Screen-shot application works if it's launched manually.

PS: Still does not work perfectly neither in 15.04

  • 2
    In case you face this problem only at times, you may have forgotten to close the previous print screen dialog . The new print screen won't work until the previous dialog is closed. Once you close, you find it will work fine. It would have been better if ubuntu brings the existing screenshot dialog to the front when print screen button is pressed, to avoid confusion. – rpattabi Jul 19 '15 at 3:03

My PRTSC button also didn't work for a brief moment, and I haven't figured out what caused it, as after reboot it started working again; however what i can offer is a workaround - you could set an alternative shortcut to taking screenshot

The default program to take screenshots in Ubuntu is, as you may now, gnome-screenshot . You could open System Settings -> Keyboard -> Shortcuts, and under custom shortcuts press plus button.

A menu such as bellow will appear, where you can enter description and actual command to run.

enter image description here

In the name field enter the description. In the Command field, well, enter the command. In my example, I've linked gnome-screenshot -w, which is "take screenshot of current window". For more information on gnome-screenshot options, refer to man page (man gnome-terminal).

Now after you have entered name and command, press apply, and you will see this custom shortcut be added to your list. Click on the "Disabled", and the text should change to "New accellerator". This is where you set a new shortcut, for instance Super+Shift+P.

Among other things, you could try resetting settings for keyboard to default as shown in this post, but I believe it's a bit to extreme step for such simple problem.

I've also found that for some folks changing kernel.sysrq in /etc/sysctl.d/10-magic-sysrq.conf helped, but I believe it to be unrelated; with PRTSC button inactive and active, that value was the same , 176.

  • 1
    Now works with a custom shortcut. – Dumitru Cristian Oct 29 '14 at 17:44
  • sudo apt install gnome-screenshot - sorted. – Ken Sharp Nov 15 '16 at 1:13

If the print button randomly stops working, please ensure that the previous print screen dialog box is actually closed first. The print button will not work until then(seems apparent but can happen if you are jumping back in forth between applications a lot).


The reason for the above is your print screen dialog is already opened somewhere. Probably you pressed print screen and the dialog of save screenshot is minimized or still open. Try closing the dialog and then use the print screen again.

I wondered if the print screen actually worked. I opened Pinta and pasted my screen shot and it displayed an error saying, the Image cannot be pasted. One of the reason could be your print screen is not working and the other one could be that you don't have and image in your clipboard.

I am using Ubuntu 14.04

Pinta is just like MS Paint in Linux. You can download it fro the software centre.


Having an error window open (related to some faulty screen resolution) caused this issue for me. Simply closing it solved the problem.

The strange part was that it wasn't a print screen dialog box.


This happens due to permission of /home/<user>/Pictures/ is changed

You can simply solve this problem by this command:

$ sudo chmod -R 777 Pictures

Do this from user HOME folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.