I'm new to ubuntu and i'm having all sorts of problems,

My wifi connection is super slow and intermittent, sometimes it randomly disconnects so I was wondering how do I go about to update the drivers for the adapter?

Also, it keeps blinking when transfering data which I find extremely annoying, I have read and tried diferrent solutions about editing the wlan.conf file and adding options iwlwifi led_mode=1 but it doesn't work for me, and I'm guessing it has something to do with the driver, I feel like i'm missing a line or using a setting for an intels adapter rather than an atheros.

I'm using Ubuntu 14.04 64 bits in a HP Pavilion DV7-1245dx.

 *-network               
       description: Wireless interface
       product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlan0
       version: 01
       serial: 00:24:2b:21:93:d7
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=3.13.0-29-generic firmware=N/A ip=192.168.2.7 latency=0 link=yes multicast=yes wireless=IEEE 802.11bg
up vote 0 down vote accepted

Install the dependencies required to compile the driver:

sudo apt-get install --reinstall linux-headers-generic linux-headers-$(uname -r) build-essential dkms

Go here and download the newest driver to your computer then place the file on your desktop and right click and extract here.

Then compile the driver using the directions below.

cd ~/Desktop/backports-3.15-rc1-1
make defconfig-ath5k
make
sudo make install
sudo modprobe -rv ath5k 
sudo modprobe -v ath5k

When you have an upgrade to the kernel you will need to do:

cd ~/Desktop/backports-3.15-rc1-1
make clean
make defconfig-ath5k
make
sudo make install
sudo modprobe -rv ath5k 
sudo modprobe -v ath5k
  • That actually made it worse, I couldn't connect to my network, the little wifi Icon on the top bar kept searching... Also, do you know if there's a fix for the blinking wifi led for atheros adapters? Should I add the options led_mode=1 in the ath5k.conf file? – rrriki Jun 21 '14 at 23:27
  • Added directions to install new driver and hopefully that will fix your blinking issue too. – Wild Man Jun 21 '14 at 23:56
  • Hi, thanks for your help but apparently that didn't do it either, I don't know if i'm doing something wrong, but after I put in the commands both times, what happens is that the wifi icon on the top keeps searching, even when "connected" to my network. After I reboot the computer it finally connected but the blinking continues – rrriki Jun 22 '14 at 17:05
  • Have the disconnects stopped? – Wild Man Jun 22 '14 at 18:59
  • Yes it looks like they have, but the led still blinking everytime it sends/receives data – rrriki Jun 22 '14 at 19:18

I temporarily solved this problem on Ubuntu 14.04 by running command:

sudo iwconfig wlan0 rate 54M

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.