0

The button under settings unfortunately will be reverted as soon as I reboot. Why is there no button to disable the touchpad permamently?

  • What windowmanager are you using ? – Panther Jun 20 '14 at 22:30
  • Standard Ubuntu 14.04. Unity? – empedokles Jun 20 '14 at 22:39
1

Why not creating the one yourself? There some workaround.

StartUp

  • Find StartUp Applications on dash search and start it up
  • Click 'Add' button, this will show you a dialog
  • Copy paste the following command to Command textbox :

    /usr/bin/gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled 'false'
    
  • Add Name and Comment as you like

  • Click 'Ok' button

Shortcut Bind

Or, you can bind the following toggle script with keyboard in the setting

  • Go to [System Settings] => [Keyboard] => [Shortcut] => [Custom Shortcut] => [+].
  • Fill Name as you like
  • Fill the command something like the following

    state=`/usr/bin/gsettings get org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled`; if [ "$state" == "true" ]; then /usr/bin/gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled 'false'; else /usr/bin/gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled 'true'; fi
    
  • Click Ok

  • Customize the shortcut.
0

Try installing the touchpad-indicator applet utility which will place a indicator icon of which you can quickly disable/enable the touchpad with and see if that works and sticks during a reboot. You will need to add this ppa, here are the install details.

Open up Terminal and issue:

sudo add-apt-repository ppa:atareao/atareao

sudo apt-get update

sudo apt-get install touchpad-indicator

FYI - I don't have this issue and can't reproduce it using a Lenovo Thinkpad with 14.04 Unity (Stock install). So if touchpad-indicator doesn't work either, then you may have something else going on.

  • You got a button to permanently disable it under settings? I'm using a Lenovo Thinkpad Edge 130. – empedokles Jun 21 '14 at 9:54
  • Yes there is a on/off slider type button switch. I turned it to off and the touchpad is then disabled immediately and for reboots or complete shutdown. You don't have this button? – Keith Pawson Jun 22 '14 at 2:02
  • I have this button under settings. But it only will work for the current session. On each reboot the touchpad is turned back on. – empedokles Jun 23 '14 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.