16

According to the TeX Live website TeX Live 2014 was released one week ago (14 June 2014). How do I upgrade from TeX Live 2013 to TeX Live 2014 on Ubuntu 14.04 ?

  • 3
    Even worse, the TeXLive 2013 version included in Ubuntu stopped working with tlmgr: tlmgr: The TeX Live versions supported by the repository [...] (2014--2014) do not include the version of the local installation (2013). – gertvdijk Sep 1 '14 at 8:53
  • @gertvdijk Yes the same happend to me. So I was forced to install TeX Live 2014.. – Håkon Hægland Sep 1 '14 at 12:50
  • After following the selected answer, I am still getting the same error as @gertvdijk. Any suggestions? – modulitos Oct 20 '14 at 23:53
  • @Lucas You did not follow all steps then. You've probably missed the PATH changes or to log out and log back in after as you're getting the old tlmgr... – gertvdijk Oct 21 '14 at 0:18
  • Yes, I even re-did the install (full, default, installation) and checked everything over. tlmgr --version says 2014 but tlmgr update --self and tlmgr update --all give the error from your first comment. All latex commands work fine, and use /usr/local/texlive/2014/bin/.. so I guess I'm ok for now. Any clarification on the tlmgr update error would be helpful. – modulitos Oct 21 '14 at 3:44
15
  1. Download the "netinstaller" for TeXLive install-tl-unx.tar.gz from any CTAN mirror, e.g. this one.

    This "netinstaller" is not a full download, but just a small executable and will download all packages from the internet based on the requirements you set later. For more information, see the install guide.

  2. Extract it somewhere, e.g. in ~/texlive/2014.

    mkdir ~/texlive/2014
    cd ~/texlive/2014
    tar -xf /path/to/install-tl-unx.tar.gz
    cd install-tl-20140831 # depends on your installer version, adjust to your situation
    
  3. Run the install-tl binary with root privileges, e.g. (adjust to your situation):

    sudo ./install-tl
    

    Note: If you have a single-user machine, or don't have root privileges, I would recommend installing to your home directory instead (omit sudo in the previous command). The reason is that commands like tlmgr (see below) will not work out of the box if they are run with sudo, see Setting TeX Live path for root for more information.

    Optionally:

    • Add the -select-repository option in order to select a CTAN mirror nearby before downloading anything.
    • Add the -gui=perltk option to use a GUI installer. Install the perl-tk package first! (sudo apt-get install perl-tk) See the screenshot below how it should look like.
    • Configure only specific collections by choosing the menu option C to save bandwidth and space. Be warned: the default set of 47 collections will yield more than 2GB of traffic and disk usage. You can always install more collections later with the TeXLive package manager (tlmgr) and the collection--prefixed meta-packages.
  4. Choose I for install in the menu. (If not in GUI mode)

    It installs in /usr/local/texlive/2014 by default.

  5. The installer output suggests to adjust some environment variables. Do so by editing your ~/.profile (or ~/.bashrc if you like) and add the following lines:

    TEXDIR="/usr/local/texlive/2014"
    export PATH=$TEXDIR/bin/i386-linux:$PATH    # for 32-bit installation
    export PATH=$TEXDIR/bin/x86_64-linux:$PATH  # for 64-bit installation
    export INFOPATH=$INFOPATH:$TEXDIR/texmf-dist/doc/info
    export MANPATH=$MANPATH:$TEXDIR/texmf-dist/doc/man
    

    Log out and log back in to receive the new variables, or, source the file, e.g. source ~/.profile to activate it for your current shell. This last step should make sure your application actually use your new 2014 local TeXLive installation rather than the Ubuntu packaged one. Some tools will require you to configure that yourself, see for example this on TeXWorks.

    Here's how the GUI installer looks like:

    install-tl

  6. Finally, to install new packages you need to setup a Texlive package database (TLPDB). See this post for more information. In summary, you have to run:

    sudo apt-get install xzdec
    sudo tlmgr init-usertree
    

    then you can install a new package, for example, to install package wrapfig, run:

    sudo env PATH="$PATH" tlmgr install wrapfig
    

    or if you installed in your home directory, you can omit sudo:

    tlmgr install wrapfig
    
  • 2
    this is correct. You can use tlmgr update --self and tlmgr update --all to keep your installation up-to-date. – puredevotion Jun 30 '14 at 17:15
  • 1
    The 2014 release is not yet available from the repositories, so right now a manual install is the only way to do it. The downside to this approach is that you will to manage the updates yourself. – Luís de Sousa Jul 7 '14 at 12:01
  • 1
    Is it available from repositories yet? If not, when? Do I have to add some PPA or will it be available as a "normal" update in Ubuntu 14.04 LTS? Thanks. – Slazer Jul 27 '14 at 14:41
  • 1
    Make sure to set the required collections with the C option in the menu, otherwise it downloads 2896 packages and takes 20 minutes on my 100Mbit internet connection... I don't want to install all TeXLive packages... – gertvdijk Sep 1 '14 at 8:59
  • 1
    sudo tlmgr init-usertree does not work for me ("command not found"), but running it without sudo works. – Julian Schuessler Nov 16 '15 at 16:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.