9

My street view in google maps stopped working in a recent update. It starts ok, and I can rotate the view, but when I move to another location I only get a black screen, and need to reenter googlemaps from the front page to get normal view again

  • What browser is this in? (I've been getting annoyed with Firefox over this). Does it look like this? – Wilf Jun 20 '14 at 21:37
  • 2
    Firefox, and it indeed looks like that. Wonderful, no? – m10 Jun 20 '14 at 21:42
  • 1
    I have been having this problem for a while and have tried the fixes here to no avail. I haven't had this problem in browser like Chrome, so I suspect it could just be Google being evil (or not having ht latest version of flash, which in Firefox on Linux is difficult)... I will look for a solution anyway. – Wilf Jun 20 '14 at 21:48
  • I think a solution to this might be to get Firefox to use the latest version of flash - Note to potential answerer's - I will add a bounty to this question once the 2 day thing has passed. - still working on it, this is weird... – Wilf Jun 20 '14 at 22:27
  • ok... I managed to get flash 14 (with this) to run in Firefox 30 on Ubuntu 14.04... and it made absolutely no difference. google and their stupid stuff... – Wilf Jun 20 '14 at 23:04
9

Go to "chrome://flags" in your browser. There, under Experiments enable "Override software rendering list" and enable the "Disable WebGL" option and relaunch the browser.

3

This isn't really a solution to the problem, but more like a band-aid. If you click on the "?" help-bubble icon, you can select the option to use the classic Google maps. That seemed to work for me using Chrome on Linux -Version 36.0.1985.125 .

0

Ok, I have the same problems. Seems to be a Google+Firefox problem.

Google has no "whitelisted" Firefox on Linux for the new Google Maps.

But you can force it using this link: https://www.google.com/maps/preview/?force=webgl

Using that address I can see Street View without black screen!

You can read a little more here: https://support.google.com/maps/answer/3031966?hl=en

Using this complete WebGL Google maps seems to work fine. A little slow compared with Chromium, but that's okay.

You can also «play» with the acceleration and WebGL settings from Firefox: webgl.force-enabled webgl.msaa-force layers.acceleration.force-enabled

from about:config

I have an AMD/intel hybrid card on Dell 3450. But on AMD and Intel seems to work fine.

0

Disabling Chrome's hardware acceleration fixed this issue for me.

To do this [version 41.x]:

  1. Go to Settings then scroll down and click Show advanced settings…
  2. Scroll down further and look for the option Use hardware acceleration when available. Make sure the option is un-checked.
  3. Reload your browser and that’s it. You can now see the black screen is already gone.

Link for a full walkthrough: http://learn.yancyparedes.net/2014/08/fixing-google-maps-black-screen-display-on-google-chrome-running-on-ubuntu-14-04/

  • Although your answer is 100% correct, it might also become 100% useless if that link is moved, changed, or the main site just disappears... :-( Therefore, please edit your answer, and copy the relevant steps from the link into your answer, thereby guaranteeing your answer for 100% of the lifetime of this site! ;-) You can always leave the link in at the bottom of your answer as a source for your material... – Fabby Feb 2 '15 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.